[#11076] - Inconsistant Dimensions

Category:
Bug report
Priority:
None
Status:
Assigned
Project: Severity:
Minor
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
0

When a featured dimensional properties are changed, they are never returned in the intended value.

Eg. I resize a feature to be 15mm and it becomes 14.99, likewise, i can set something to 5 and it becomes 5.3.

Likewise when sections are resized, they never end up being the dimension which i drag them to be.

I understand there is a correlation between px and mm but it cant be to the level i'm seeing here.

v6.3
Jaspersoft® Studio Pro
adam.ramage's picture
Joined: May 21 2017 - 5:02pm
Last seen: 2 years 3 months ago

3 Comments:

#1
  • Resolution:Open» Unable to Reproduce
  • Status:New» Assigned
  • Assigned:nobody» morlandin

Hi, can you test with the last version? 5mm are converted to 4.94px and it is correct because JasperReports internally works only with pixels, so every measure unit must be converted from and to pixels and it also depends by jr dpi (by default 72), so every value with a measure unit different from pixel is rounded to the nearest value. If you are still able to reporduce with the last build can you share the report?

#2

Issue only exists with JR Professional 6.3. Community version 6.5.1 i wasnt able to replicate

The details of how much they vary is figurative. I could drag an element to resize by 1mm or a a few px and it would move 10x the distance.

#3
  • Priority:Urgent» None
Feedback