[#10956] - when I add static text in Jasper Studio, it is frozen and doesn't response

Category:
Bug report
Priority:
None
Status:
Feedback Requested
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
1

I'm running Jasperoft Studio 6.6.0 on Ubuntu 18.04 LTS .
Whenever I create new empty report and I add static text on Page Header with Jasper Studio 6.6.0 , it is frozen and doesn't response.
I happens every time. I'm considering to downgrade version.

AttachmentSize
Image icon frozen.png75.18 KB
v6.6.0
skiver2003's picture
Joined: Mar 16 2016 - 7:40am
Last seen: 1 year 2 months ago

9 Comments:

#1
  • Status:New» Confirmed

Hi I can confirm that there is an issue.
It seems to be present the first time you add a static text item to the report.
The problem seems to be more evident in the Linux installations, but it is present also on the other systems. The freeze is temporary and subsequent drags of static text behave normally.
We investigated the problem and it seems related to some API loading the font/font extensions. We are going to verify with the JR team if it is a regression on JSS side or something triggered by possible JR modifications.

Thanks for spotting.
Regards,
Massimo.

#2
  • Status:Confirmed» Feedback Requested

Hi it appears after a further investigation that the problem is related to the JRE version bundle with JSS. It seems that the SunGraphics2D#getFontMetrics is taking long time. Not sure why. It seems a JRE bug (??).
Trying to switch to an older version of the JRE seemed to fix the issue. I tried with a 1.8.0u144 and 1.8.0u151 and they worked fine. On the other side the 1.8.0u161 is not working fine as the 1.8.0u171 that is bundled with JSS.

In order to workaround the issue, you can try to replace the "jre" folder inside the <jss_installation>/features/jre.linux.gtk.x86_64.feature_1.8.0u171 with an older one. For example you could take the one in JSS CE 6.5.1 that is using a 1.8.0u144.
Another solution is to modify the Jaspersoft Studio.ini file in the installation folder so it points to an older JRE instance location.

Let us know if this workaround fix the issue.

Best regards,
Massimo.

AttachmentSize
Image icon slowjss.png1.13 MB
#3

Same problem here,
Copy jre 1.8.0u144 from JSS CE 6.5.1
work fine.

#4
  • Priority:Urgent» None

The indicated workaround worked for me.
- From 6.5.1 copy the jre.linux.gtk.x86_64.feature_1.8.0.u144 folder inside <jss_installation>/features
- Modifiy "Jaspersoft Studio.ini" changing "u171" with "u144"

#5
  • Resolution:Open» Fixed
  • Status:Feedback Requested» Resolved

I'm closing the bug as resolved. We decide to move back with the bundled JRE. The next JSS version will ship version 1.8.0.u151, the last available that does not show the problem.

Best regards,
Massimo.

#6

jre.linux.gtk.x86_64.feature_1.8.0.u144 solved the issue of my Ubuntu 16.04 too. Thank you!

#7

jre.linux.gtk.x86_64.feature_1.8.0.u144 solved the issue of my Ubuntu 18.04 too. Thank you!

#8
  • Resolution:Fixed» Open
  • Status:Resolved» Feedback Requested

Have some notice by the plugin version of Eclipse?

I'm running the 6.5.1 version of JSS in Ubuntu 18.04 as plugin for the Eclipse IDE but when i open a .jrxml file i get first an error showing there's something wrong with data adapter and then i got stuck into the slowly problem mentioned before, i can't use JSS in this way.
i'm using 6.5.1 because version 6.6.0 has the same problem and i've tried like you've suggested to downgrade version and trying older version of JRE too, writing it directly in the eclipse.ini file, for the -vm properties but nothing changed.

For example if i can reach the opening of the jrxml file i can do one click on one random item on the report and then other actions i'll take are not refreshed by the UI of the report but, the weird thing, is that the box reflecting objects selected is correctly changing by my actions, i'm talking about the outline view in the report desing perspective.

Can you find a solution for the plugin version too?

Thanks,
Mattia

#9

Las propiedades en Outline Parameters aparecen vacías

Feedback
randomness