[#10246] - Server upload: Style template reference overwrite with subreport not working

Category:
Bug report
Priority:
Normal
Status:
Resolved
Project: Severity:
Minor
Resolution:
Fixed
Component: Reproducibility:
N/A
Assigned to:
0

I have a report which consists of a main template and one subreport template. Both templates are referencing the same style template file which is located in the same folder in the workspace.

When I upload the report to the JasperReports Server, my styles file is showing up with other resources in the publish wizard correctly. I use "Overwrite" for the styles file with expression "repo:Styles.jrtx" and all resources including the Styles.jrtx are correctly uploaded to the server.

The problem is now: when I execute the report, I get an error that the byte data for the Styles.jrtx isn't found. The path shown in the exception is the path from my local workspace.

(net.sf.jasperreports.engine.JRRuntimeException: net.sf.jasperreports.engine.JRException: Byte data not found at: CCM/Chargenbericht CCM/Styles.jrtx. at ...)

So I checked the templates on the server - first the main template and it was showing the correctly overwritten style template source expression "repo:Styles.jrtx". But when I was looking at the subreport template, if found out that the subreport template still had the local expression. It wasn't overwritten during upload and this is the reason why I'm getting the exception when filling the report on the server.

The report publishing wizard is making me crazy not the first time. I have also troubles with uploading resource bundles what I have reported already some weeks ago (see: https://community.jaspersoft.com/jaspersoft-studio/issues/9956)

v6.4
asprom's picture
10
Joined: Nov 25 2013 - 5:31am
Last seen: 1 week 5 days ago

3 Comments:

#1
  • Resolution:Open» Unable to Reproduce
  • Status:New» Resolved
  • Assigned:» chicuslavic

I tested on the last version, both report and subreport expressions are rewrited. Please upgrade your Jaspersoft Studio to the last version, you could take CE. Add a sample if you still have problems.

#2
  • Status:Resolved» Feedback Requested

Tested again with version 6.5.1 and still the same error.

#3
  • Resolution:Unable to Reproduce» Fixed
  • Status:Feedback Requested» Resolved

Thank you for your sample, I fixed the problem. Unfortunately, you have to wait for a new release.

Feedback
randomness