[#10216] - Crosstab with row groups not the same height

Category:
Bug report
Priority:
Normal
Status:
Closed
Project: Severity:
Minor
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:
0

In a crosstab with 2 or more row groups, the nested group cannot have the same height of the head group, if the head group var have dynamic height
please see image

CrossTab
ingborrigiorgio's picture
Joined: Sep 12 2017 - 6:42am
Last seen: 5 months 5 days ago

3 Comments:

#1
  • Status:New» Assigned
  • Assigned:» morlandin

Hi, The image refers to the crosstab on the final report right? or is it the crosstab you see in the designer? From your screenshot it seems in the preview tab, so I'd say we are in the first case. Because if the crosstab is correct in the designer but wrong in the preview it could be a JasperReports bug more than a JSS one.

#2

Hi @morlandin
You are right, the screenshot came from the preview tab of JasperStudio 6.5.0.
But the same problem is present in the final pdf document.
In the report I have two row groups: product and sale_reference, and in the corresponding text field, I have checked the "Resize if necessary" checkbox. But if the head group (product) resize his height, the following group (sale ref) don't adapt the height till the new container height
The problem is due to the large description of the head row group, so for the Resize if necessary checkbox his height is correct, but not change the crossbar line height, that depends on the height of the last row group.
In the last row group I've tried all the options on Properties Appearance-> Stretch Type but all without success

AttachmentSize
Image icon schermata_2017-12-22_alle_12.15.04.png475.61 KB
#3
  • Resolution:Open» No Change Required
  • Status:Assigned» Closed

Hi, the "resize if necessary" (called "stretch with overflow" in english) simply increase the height of the textfield when the text is too long, until the text can fit. I don't know if the crosstab cell should be supposed to resize aswell. Also the row group doesn't have a property strech type, so proprably you're referring to the content of the cell, which in appearence has the property Stretch Type. However this property define how the element can grow in its container, but doesn't affect the container itself.
I think the size of the cell is fixed, and if you want to use the "stretch with overflow" property then you should make the cell high enough to contain completely the textfield.

But if you feel this is a bug you should open a new bug in the JasperReports Library project (the tracker is in this same site), because JSS handle only the design of the report and in this case it seems correct. Everything like the preview, exporting and generation of the final report belong to the JasperReports Library.

Feedback