[#10061] - unable to resolve class net.sf.jasperreports.compilers.GroovyEvaluator

Category:
Bug report
Priority:
Urgent
Status:
Feedback Requested
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:

Hi

After the upgrade from versione 6.3 to 6.4.3, I receive the following Error when i try to create a preview:

calculator_report20_Dataset4_1509375750658_265571: 18: unable to resolve class net.sf.jasperreports.compilers.GroovyEvaluator
@ line 18, column 1.
calculator_report20_Dataset1_1509375750658_265571: 18: unable to resolve class net.sf.jasperreports.compilers.GroovyEvaluator
@ line 18, column 1.
calculator_report20_CROSSTAB0_1509375750658_265571: 18: unable to resolve class net.sf.jasperreports.compilers.GroovyEvaluator
@ line 18, column 1.

The report worked without error in JasperStudio 6.3.

Thanks

v6.4
morisbozzetto's picture
Joined: May 26 2014 - 2:27am
Last seen: 2 weeks 2 days ago

4 Comments:

#1
  • Severity:Minor» Major
  • Status:New» Confirmed

Still same error with 6.6.0, when groovy is used in a report, the validator is not able to find groovy classes.
You can't :
- run the report
- add a new dataset
- edit the query and use "read fields"

#2

Hi, did you tried with a clean installation ?
Can you please provide a sample report that is actually causing the issue?

Regards,
Massimo.

#3
  • Status:Confirmed» Feedback Requested
#4

I think that is similar to: https://community.jaspersoft.com/jaspersoft-studio/issues/9476

Try to test with this groovy jar version.

Mariano

Feedback