[#10051] - Studio V6.4.3, V6.5.0 & V6.5.1: Copying or moving fields discards size AND appearance

Category:
Bug report
Priority:
Immediate
Status:
Closed
Project: Severity:
Block
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

Hi,

PROBLEM:
When dragging of copying fields, studio discards style formatting and size. See: https://cl.ly/0v3E0N3k3G0e

REPRODUCE:
The issue arises when you have you have Element Templates enabled, see: https://cl.ly/461U3o0d3u1R

RESULT:
When enabled, the Studio also resets the pasted element to the template as if it is a new element.

Kind regards,
Maarten

v6.4.2
mvcoile's picture
120
Joined: Apr 28 2014 - 2:15am
Last seen: 1 week 5 days ago

10 Comments:

#1

I'm not able to reproduce this one doing your exact operations, can you share the report?

#2
  • Assigned:» morlandin
#3

I'm not able to reproduce it too, could you add your jrxml?

#4
  • Reproducibility:Always» Unable to Reproduce
#5
  • Reproducibility:Unable to Reproduce» Always

@morlandin: even reproducible in 6.5.0, see: https://cl.ly/2V3Z180Z2i02

Note, this is on macOS 10.13.1 (17B1003)

#6
  • Priority:Normal» Immediate
  • Severity:Critical» Block
#7

@morlandin: even reproducible in 6.5.1

Note, this is on macOS 10.13.2 (17C89)

#8
  • Status:New» Confirmed

@morlandin: The issue arises when you have you have Element Templates enabled, see: https://cl.ly/461U3o0d3u1R

When enabled, the Studio also resets the pasted element to the template as if it is a new element.

AttachmentSize
Binary Data template_15x100_excel.jrxml5.57 KB
#9
  • Resolution:Open» Fixed
  • Status:Confirmed» Closed

Thanks, I've reproduced and fixed the bug. On the next communuty release this problem should be gone.

#10

@morlandin: thx!!

Feedback