[#10046] - Can't save or publish main report in Studio 6.4.0

Category:
Bug report
Priority:
Normal
Status:
Closed
Project: Severity:
Major
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
1

Have updated my Studio version to 6.4 but have encountered an issue where the main (MainJrxml usually) report cannot be saved or published to server - I've tried using both the menu items and toolbar buttons but nothing happens. This only applies to the main report though as I can save and publish subreports within a reporting unit, but I can't save or publish any of the main reports across any of our JasperServers.

Our Jasper Servers are still on 6.2.0 but I specified that when I set up the connections.

jonathon.jones's picture
Joined: Jan 18 2015 - 1:53pm
Last seen: 9 months 2 weeks ago

13 Comments:

#1
  • Severity:Minor» Major
  • Reproducibility:N/A» Always
#2
  • Status:New» Feedback Requested

Hi can, you please give it a try with the latest 6.4.3.
I think there were some fixes on this area.

Regards,
Massimo.

#3

Where do I find this? I can't see it in the downloads section of the Support Portal, only 6.4.0

#4
  • Status:Feedback Requested» New

I've managed to find a Community Edition version, but how about Professional Edition?

#5
  • Status:New» Feedback Requested

There is no Professional version for 6.4.3. It was a Community release only.
As far as I understood you are a paying customer (mentioned support portal). I suggest you open a case to the support guys so they can handle the proper way, and if needed/possible we will provide a patch.
Anyhow it would be nice if you are able to confirm that with Community version you are able to publish to JRS.

Regards,
Massimo.

#6

Okay I downloaded and installed the Community Edition, unfortunately I still encountered the same issue though, subreports can be saved and published, main reports cannot.

#7

I encounter the same problem: Saving the report shows the save dialogue, but the file is not saved at all (and the "*" mark (file altered) still remains active).
Tested with 6.4.3 and an existing (old) report.
Saving of non-main-reports are working without any issues.

#8
  • Resolution:Open» Unable to Reproduce
  • Status:Feedback Requested» Resolved
  • Assigned:nobody» chicuslavic

I tried to reproduce this bug and I can't. Please add a screenshot or exact steps.

#9

I am having this problem too in Jaspersoft Studio 6.4.2. I am a consultant for a paying customer.

#10
  • Status:Resolved» New

I tryed to use version 6.4.3 but it has no oracle driver

#11

We have this problem too in Jaspersoft Studio 6.4.2

#12
  • Resolution:Unable to Reproduce» Open
#13
  • Resolution:Open» Unable to Reproduce
  • Status:New» Closed

Closing the bug because it has been fixed as mentioned (in the comments above) in the previous Community releases.
If you are having the problem with the Professional version(s) please do not re-open here. But refer to the support portal and open a case there.
The bugs related to professional versions must be handled differently so it make no sense to keep re-opening an already closed/fixed bug in the Community tracker.

Depending on your version, you might need to upgrade to the last version.

Regards,
Massimo.

Feedback