[#9416] - Text overflow in PPT-export

Category:
Bug report
Priority:
Low
Status:
Closed
Project: Severity:
Minor
Resolution:
Not Fixable
Component: Reproducibility:
Random
Assigned to:
0

There is a text field, which streches with overflow as the amount of text input is variable. When there is more text than space, it creates a new page. Sometimes, the text is printed inside the footer. This happens only in ppt-export, pdf is fine. Also, it does not happen in Jaspersoft Studio, but only in combination with Jaspersoft Server embedded in CA PPM.
Any ideas how to circumvent this issue? Thanks!

I am aware that this bug is also described in another report (#7186), but as it is more than a year old and still unanswered, it is better to open a new ticket.

AttachmentSize
Image icon jaspersoft.png82.74 KB
elise.ross@itdesign.de's picture
Joined: Apr 3 2017 - 6:11am
Last seen: 1 week 6 days ago

4 Comments:

#1

Hi,

First of all, the PPTX format is not quite "pixel perfect", because we can't control the rendering to very high degree of precision.

But I see you are using a CustomArial font for your text field.

Is this font mapped to an actual font that would exist on the machines that view the PPTX file using MS PowerPoint?

In case the font does not exist on the client machine viewing the document, it probably gets replaced with some default font which has different font metrics and fits differently in the text box element.

Thank you,
Teodor

#2
  • Status:New» Feedback Requested
  • Assigned:nobody» teodord
#3
  • Priority:Normal» Low
  • Reproducibility:Always» Random

Hi Theodor,
thank you for the feedback, I will check this on customer site an let you know if the missing font caused the issues!
Best regards
Elise

#4
  • Resolution:Open» Not Fixable
  • Status:Feedback Requested» Closed

Hi Theodor,
we now checked the setup. Indeed, we had to use a CustomArial because of another bug which prevented bold letters in pdfs.
However, in ppt-format, it then got replaced by standard Arial. But you are probably right and something is getting mixed up in this setup by the CustomArial font.
We could resolve this issue by manual customization of the text fields, so that a new line break could not interfer with the footer.
Best regards!
Elise

Feedback
randomness