[#6546] - Include HTML report in email body always sends ZIP on Linux

Category:
Bug report
Priority:
High
Status:
Feedback Requested
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

I just installed JasperServer 6.2.0 on my 64-bit Red Hat Linux box and I'm having issues sending scheduled reports that I wasn't having running JasperServer on my Windows laptop.

When I schedule a report with an HTML output type and select "Include report files as attachments" and "Include HTML report in email body" the report is always send with a ZIP attachment, even though I did NOT select "Include report files as ZIP attachment". My organization does not allow ZIP attachments in email, so the report always ends up bouncing.

If I schedule a report with an HTML output type and select "Include report files as attachments" and do not embed the HTML in the email body the report is attached as a .html file and no ZIP is created.

This is only happening on the Linux box, running the exact same report and scheduler settings works fine on the Windows machine.

v6.2.0
kb23's picture
4
Joined: Dec 2 2015 - 1:52pm
Last seen: 4 years 8 months ago

6 Comments:

#1
  • Severity:Minor» Major
#2
  • Status:New» Feedback Requested

Has this issue been resolved?

#3

No, I was forced to use 6.1 in order to send HTML emails without ZIP attachment.

#4

Hi,
I am not able to use option include html file while scheduling the reports as that option looks like hidden. can any find any workaround for the same?
Thanks
Pawan

#5
  • Priority:Normal» High

@pawankumar.singh : facing the same issue that option (Include HTML report in email body) is not enabled. jasper version 6.6.0 please help!!!

#6
AttachmentSize
Image icon error_html_report_in_email_body.jpg22.84 KB
Feedback