[#4911] - QR code + JasperReport Server 6.1

Category:
Bug report
Priority:
High
Status:
Resolved
Project: Severity:
Critical
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

The new QR Code Component is is working fine in the Jaspersoft Studio 6.1.

On the JasperReport Server the QR Code is blank(only the background) is shown

v6.1.0
Areport's picture
88
Joined: Aug 2 2011 - 6:41am
Last seen: 2 years 5 days ago

8 Comments:

#1

Seems to work fine for me. Please attach a self contained JRS export catalog to reproduce the problem.

Regards,
Lucian

#2
AttachmentSize
Package icon export_qrcode.zip2.55 KB
#3

Can't get this to work either. I just added barcode4j qrcode on to a report without anything else. JSS shows the qrcode but JRS does not.
I've attached my jrxml and screenshot on JSS and JRS.

AttachmentSize
Package icon qrcode.zip36.63 KB
#4
  • Resolution:Open» Fixed
  • Status:New» Resolved
  • Assigned:nobody» teodord

Hi,

The problem seemed to be related to an empty xmlns="" attribute in the <rect> tags of the SVG created by the QR code component. This attribute was generated empty only when in JRS, probably due to a different DOM API configuration. I have forced the namespace for the tag and the problem has been fixed.
This will be part of the next release. Until then, you either use a JR Library hotfix or change the configuration so that barcodes are generated as images, using the following config property in WEB-INF/classes/jasperreports.properties:

net.sf.jasperreports.components.barcode4j.image.producer=image

Thanks,
Teodor

#5

Thanks. Worked perfectly.

#6

I've asked Jaspersoft Support for the JR Library hotfix that was mentioned but they've told me to wait until the next release.
Is the hotfix available or not?

#7

Hi,

When I said "hotfix", I was referring to a JAR that you could build from GIT source code on your side. I was not referring to official hotfixes that Jaspersoft support offers to its customers. Here we are on the community website where open source spirit prevails. :-)

If you need official hotfix, please work with Jaspersoft support and have this issue escalated if needed.

Thanks,
Teodor

#8

Thanks the reply. Will check on git.

Feedback
randomness