[#4127] - Jasper Rest V2 - Error : mailNotification.length when scheduling report

Category:
Bug report
Priority:
Urgent
Status:
Feedback Requested
Project: Severity:
Critical
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:

When scheduling a report through the Rest V2 API for Jasper Server I am getting this error :

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<errors>
<error>
<defaultMessage>Maximum length is {0,number,integer}.</defaultMessage>
<errorArguments xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xs="http://www.w3.org/2001/XMLSchema" xsi:type="xs:int">100</errorArguments>
<errorCode>error.length</errorCode>
<field>label</field>
</error>
<error>
<defaultMessage>Maximum length is {0,number,integer}.</defaultMessage>
<errorArguments xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xs="http://www.w3.org/2001/XMLSchema" xsi:type="xs:int">100</errorArguments>
<errorCode>error.length</errorCode>
<field>baseOutputFilename</field>
</error>
<error>
<defaultMessage>Maximum length is {0,number,integer}.</defaultMessage>
<errorArguments xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xs="http://www.w3.org/2001/XMLSchema" xsi:type="xs:int">100</errorArguments>
<errorCode>error.length</errorCode>
<field>mailNotification.subject</field>
</error>
</errors>

I have changed all maxLength values for these variables in the /WEB-INF/classes/esapi/security.properties as follows :

mailNotification.subject=AlphaDot,!Script,500,true,mailNotification.subject-ViewRepository_Schedule_OutputSettings_context
baseOutputFilename=Alpha,AlphaNumPunctuation,500,true,baseOutputFilename-ViewRepository_Schedule_OutputSettings_context
label=Alpha,AlphaNumPunctuation,5000,true,label-ViewRepositoryEdit_context
reportUnit.label=AlphaDot,ReportUnitName,250,true,reportUnit.label-ViewRepositoryEdit_context

Each field above in the job descriptor XML that I am sending is just over 100 characters. I know the limit is 100 characters and I have changed the variables in the security.properties file and restarted Tomcat7. The changes are not applied.

Is this a bug??

v5.6.1
moody.youssef's picture
Joined: Aug 4 2014 - 8:03am
Last seen: 1 year 1 month ago

1 Comment:

#1
  • Assigned:nobody»

Any update to this??

Feedback
randomness