[#3923] - "'JSON' is undefined" error when using IE 8

Category:
Bug report
Priority:
Normal
Status:
Closed
Project: Severity:
Major
Resolution:
Won't Fix
Component: Reproducibility:
Always
Assigned to:
0

We just upgraded from 5.2 to 5.6.1 and noticed this issue with IE 8. When attempting to view a report, JavaScript console reports the following errors:

Message: 'JSON' is undefined
Line: 306
Char: 5
Code: 0
URI: http://<<webserver>>:8080/jasperserver/flow.html?_flowId=viewReportFlow&standAlone=true&_flowId=viewReportFlow&ParentFolderUri=%2Freports%2FStudy_107&reportUnit=%2Freports%2FStudy_107%2FCollection_Summary_by_Collection_ID

Message: 'i.reportViewer.ReportSettings' is null or not an object
Line: 23
Char: 7189
Code: 0
URI: http://<<webserver>>:8080/jasperserver/optimized-scripts/report.viewer.page.js

According to http://stackoverflow.com/questions/5339232/json-is-undefined-error-in-ja..., IE 8 does not natively support JSON and a JSON parser must be added. I checked the source code of our 5.2 instance and sure enough, it looks like the same "flow.html" page does not use JSON directly.

I tried to follow the directions within stackoverflow but am unfamiliar with how to add the JSON.js library to the stack.

Manually changing the Document Mode out of "Compatibility Mode" seems to fix this issue. Anyway to add the JSON parser so that IE works out of the box?

v5.6.1
scubamike's picture
Joined: Sep 23 2014 - 10:54am
Last seen: 3 years 7 months ago

5 Comments:

#1

IE8 was a supported browser in version 5.6.1 of JRS. This may be a browser cache issue. Have you tried to clear it?

#2

IE8 always was a problem with JasperReports Server and I had to make several patches. I strongly recommend that you upgrade to IE11 if that's possible.
FYR, IE8 is no longer supported by Jaspersoft.

#3

Unfortunately, I can't just use Internet Explorer 11 most of our users access JasperServer via Citrix and I don't have admin over it.

Thanks everyone!

#4
  • Resolution:Open» Won't Fix
  • Status:New» Closed

I'm closing this issue as IE 7 is not supported anymore.

#5
  • Assigned:nobody» narcism
Feedback