[#3421] - Creating Domain in Jasper server 5.2 with connection to Sybase generates an error

Category:
Bug report
Priority:
High
Status:
New
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

I tried to create a Domain in Jasper Server 5.2 connecting through datasource (JDBC) for Sybase.
And I have following Error message: "Cannot get metadata for /ERP/Data_Sources/ERP_DEV: java.sql.SQLException: JZ0SB: Parameter index out of range: 1".
I tested datasourse - the connection is good. I'm able to connect to DB.

AttachmentSize
File domain_create_err.docx219.17 KB
v5.2.0
felded53's picture
Joined: Dec 1 2010 - 8:08am
Last seen: 3 months 2 weeks ago

2 Comments:

#1
  • Assigned:nobody»

I am having the same issue. Is there a way to make this work?

#2
  • Assigned:» anonymous

Sybase is not SQL-92 compliant in some ways. It works well with reports developed in Jaspersoft Studio (JSS). However, when you try to connect it to the domain designer there are some methods that are not standard in the Sybase drivers when it comes to the retrieval of the schema - which is needed by the domain designer. (Incidently that is why Sybase is certified on community but not on commercial editions, since community does not have domains / adhoc.)

You have a variety of options to enable your users to use the adhoc design features:

1. Use JSS to create a topic. The steps to do this are covered in The JasperSoft Studio Users guide, section 5.4.

https://community.jaspersoft.com/documentation/tibco-jaspersoft-studio-u...

The topic can then be used as a basis for the adhoc designer.

2. Manually create your domain design using XML and upload it. This bypasses the domain designer with it's requirement of retrieving the schema. This will take more detailed knowledge of how a domain is put together. A starting point would be to download an existing domain as an example / starting point. This should work, although I haven't actually tried this on Sybase.

Feedback
randomness