[#3255] - JasperServer: create new scheduler fails due to com.sun.jersey.api.NotFoundException

Category:
Bug report
Priority:
Urgent
Status:
New
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
1

Hi,

creating a schedule task on an existing report that runs correctly, fails du to com.sun.jersey.api.NotFoundException.

When I click on Save button (my language is french, so translating may be wrong), the dialog opens to query task name, I type a name (i.e. cave_task), then click Save button.
The dialog box closes, but then task page stay on, and there is no forward to task list.

Attached the catalina.out

Java 1.7.0_09, linux 64bits

Best regards,
Christophe

AttachmentSize
Binary Data catalina.out119.61 KB
v5.5.0
cmarchand's picture
Joined: Oct 1 2012 - 1:22am
Last seen: 6 years 7 months ago

25 Comments:

#1
  • Severity:Minor» Major
  • Assigned:nobody»

Hello
Same for us with version 5.5, systematic behaviour.
Prevent from scheduling any report, thus a major problem.
Thank you
regards.

#2
  • Assigned:» anonymous

Hi,

I also have the same problem. In my case I upgraded from 5.2 to 5.5, I had no errors during the upgrade but since then I have no chance to schedule a new report.

It also happens when I try to edit any existing scheduled report that worked fine in 5.2

I hope this information may have to resolve this issue.
Regards,
J.

#3

Hi,
same problem here with version 5.5, but only with reports that have parameters.
I tried scheduling "Accounts Report" (one of the example reports) and it worked fine.
I hope this can narrow the problem down.
Best regards,
Simona

#4

Hi,

I have the same problem on jasper server 5.5 on windows 7.0. And it's a new installation. The customized report has 2 parameters not more. The same issue appears also with report "AllAccounts" after doing 2 modifications on the scheduler.
It worked fine 2 times after modification but after that there is no possibility to make changes on the schedule.
The name changes alos:

from:
Schedule For:/reports/samples/AllAccounts

to:
Schedule For: /public/Samples/Reports/RevenueDetailsReport

Many thanks for your help.

Best regards,

#5
  • Priority:Normal» Urgent
  • Severity:Major» Block

Hi, I just upgraded to v5.5. I have the same problem. Reports run ok from browser, but I'm not able to schedule jobs. Parameters tab is diabled and I am getting Save as pop up non stop.

#6

Regarding reports with vs. without parameters, reports without parameters could be scheduled, however the same error is visible in log file.

2013-11-29 13:36:29,181 ERROR GenericExceptionMapper,http-127.0.0.1-48080-7:42 - Unexpected error occurs
com.sun.jersey.api.NotFoundException: null for uri: http://127.0.0.1:48080/jasperserver/rest_v2/reports/Operational_Reports/...
/options

#7

I am surprised that this bug has been left open so long as an Urgent/Blocker with no response from Jaspersoft?

Not being able to schedule reports in 5.5 is a very serious issue. Some kind of response (ideally with a workaround) should be issued for this bad bug!

#8

Hi,

i stumbled accross the same problem.

I have posted my workaround at stackoverflow:

http://stackoverflow.com/questions/19709622/jasperreports-server-5-5-cre...

Best Regards

Constantin

#9

I have tested scheduling with the report that does not have parameter and I still have error in the log file, however I can save the schedule.
After that, I have not further tested since I can not consider 5.5 ready yet for the production.

Unfortunately, we will need wait for new version of JasperServer. Until then, 5.5 is useless for me.

#10

Hi,

Attached are 2 JavaScript files you need to update in order to fix the problem:
./scripts/scheduler/view/editor/parameters.js
./scripts/scheduler/collection/jobs.js

Let us know if you still encounter the problem

AttachmentSize
File parameters.js7.57 KB
#11
AttachmentSize
File jobs.js2.85 KB
#12
  • Resolution:Open» Fixed
  • Status:New» Resolved
#13

Thank you dnaboka, replacing the existing .js files with the ones you have supplied above appears to have fixed the problem :-)

For the absolute clarity of all of readers, the parent folder of the .scripts/... folder is the '{JASPER_INSTALL}/apache-tomcat/webapps/jasperserver' folder, so on a default out of the box community edition install you need to replace the following two files:
/opt/jasperreports-server-cp-5.5.0/apache-tomcat/webapps/jasperserver/scripts/scheduler/view/editor/parameters.js
/opt/jasperreports-server-cp-5.5.0/apache-tomcat/webapps/jasperserver/scripts/scheduler/collection/jobs.js

In my opinion, if this is not going to be fixed for 5.5 then at least can you document the workaround nicely please? It would be good to redirect our customers to a well-presented work around page, rather than a bug report page ;-)

But thanks again!

#14
  • Resolution:Fixed» Open
  • Status:Resolved» New

Hi Dnaboka,

I got exatly the same problem with the scheduler than Andy.C.
I install the jasperserver 5.5 and it's not working for me to schedule an execution of a report.
I did the same than andy.C with the file yo share (proeprties.js and jobs.js), i restart the server and I still have the problem : cannot get the parameters page and when I set some parameters, it's not save.

It's a severe bug from iReport, blocking our users.

Thank you.

PS : I noticed that the scheduler is working on internet explorer but it's not working when I'm using firefox or google chrome.
I also noticed that when I save my scheduler job, it save nothing but the email adresse for the notification. But when I edit this job it save it correctly (except for the specific date).

#15

Don't know why you still experience problems. You don't even have to restart application, just replace appropriate files. Try try clearing Tomcat cache (contents of jasperreports-server-cp-5.5.0\apache-tomcat\work\)

It's working for me on all browsers. Perhaps, you encounter another issue. Please open new defect if you do and list step-by-step instruction you take to reproduce it.

#16
  • Resolution:Open» Fixed
  • Status:New» Resolved

1. You can create wiki how-to article for your customers if you feel this is required
2. Issue should be fixed in next release. For 5.5 there is a hotfix (files previously attached)

#17

Works fine now! Thanks

AttachmentSize
Image icon 5_5_input_controls_vs_5_2.gif43.69 KB
#18

These two files has not solved the problem :( There is no error message in the log but when I click 'Save' button new schedule task does not appear on the list. I do not why on some report adding schedule task work (but for old reports that were created in 5.0 it does not work)

#19

its not working....any other solution

#20

These two files has not solved the problem :( There is no error message in the log but when I click 'Save' button, does not work and new schedule task does not appear on the list.

#21

If you still have issues after replacing both .js files, that's because you didn't clear your browser cache. The browser is still using the old version of the files. Close all your browser windows, open it again, clear your cache. Then it should work.

#22

These two files has not solved the problem :( There is no error message in the log but when I click 'Save' button, does not work and new schedule task does not appear on the list.
Please i nead a solution... please

#23

The two files attached by dnaboka solved my problem. Thanks for sharing this!!! To Others: Follow the procedure and clear or reset your browser. Actually my first tried is fail but in my second, I got the parameters enabled. Ensured that the report you want to scheduled has a Input Control or parameters to enable the parameter tab.

Note: I did the procedure of Dnaboka by trying to reset the browser.

AttachmentSize
File jasper_server_and_client_unit.docx141.19 KB
#24

Does anyone know if this was fixed for 5.6.1?

#25
  • Resolution:Fixed» Open
  • Status:Resolved» New
  • Assigned:nobody»

Have same problem in Jasper Server 6.3 too.
I created the job schedule for reports and dashboards with parameters via Rest PHP Client and everything works just fine except following problem with dashboard jobs.
If I try to edit the dashboard job from Jasper server UI, the "Parameters" tab is disabled and I could not edit job info. In console, I see ReportURI/inputControls//values?_=1526899933500 404 Not Found error. For report jobs there is no issue and parameter tab is enabled and I could edit them.
I was wondering about if I Can replace above JS files even if jasper server version is not same?

Feedback