[#1373] - mysql root account

Category:
Bug report
Priority:
Low
Status:
Closed
Project: Severity:
Trivial
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

Issue migrated from: https://sourceforge.net/tracker/index.php?func=detail&aid=1476631&group_...

[ 1476631 ] mysql root account

Submitted By: Heme Aqui - heme_aqui
Date Submitted: 2006-04-25 20:58
Last Updated By: heme_aqui - Comment added
Date Last Updated: 2006-04-27 21:35
Number of Comments: 3
Number of Attachments: 0

Assigned To: Sherman Wood
Priority: 5

Summary:

mysql root account

Hi,

Where is the root user is defined to connect to the localhost database?

I modified META-INF/context.xml with the corresponding mysql user and msyql password but I still keep getting the
following error. Any enlightment would be greatly appreciated. By the way, I'm using version 0.9.2.

Attempted reconnect 3 times. Giving up.) 23:32:13,033 WARN SettingsFactory,main:103 - Could not
obtain connection metadata org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (
Server connection failure during transaction. Due to underlying
exception: 'java.sql.SQLException: Access denied for user 'root'@'localhost' (using password: YES)'.

** BEGIN NESTED EXCEPTION **

java.sql.SQLException
MESSAGE: Access denied for user 'root'@'localhost'
(using password: YES)

STACKTRACE:

ETC ETC ETC

Edwin

Followups:

Comments

Date: 2006-04-27 21:35
Sender: heme_aqui
Logged In: YES
user_id=1510135

OK, I found JdbcDataSource, but even when I change the password for the 'root' user, I keep getting a
permission denied error.

Date: 2006-04-27 21:03
Sender: heme_aqui
Logged In: YES
user_id=1510135

Can't find JdbcDataSource. Where is it located?

Thanks

Date: 2006-04-25 21:14
Sender: sgwoodProject Admin
Logged In: YES
user_id=611753

We store database connection parameters in the metadata database. It looks like something is wrong. Can you edit the
JdbcDataSource and update the password?

Attached Files:
Name Description Download
No Files Currently Attached

Changes:

Field Old Value Date By
assigned_to nobody 2006-04-25 21:14 sgwood

Teodor Danciu: 02/20/2007 6:57 AM PST
Comment:

Hi,

Have you experience this problem with more recent versions of the JasperServer?
I suspect it was related to the fact that you need to configure MySQL so that it allows incoming connections from the machine that runs our
application.
It might be that the MySQL instance is denying access to all connect requests coming from that particular IP.

If you still face this problem, please reopen or repost the bug.

Thank you,
Teodor

Action: Update
Closed set to 02/20/2007
Status changed from Open to Closed

tcloonan's picture
1222
Joined: Dec 22 2006 - 1:13am
Last seen: 14 years 4 months ago
Feedback
randomness