[#1372] - [v0.9.2] java.util.Date parameters

Category:
Bug report
Priority:
Low
Status:
Closed
Project: Severity:
Trivial
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:

Issue migrated from: https://sourceforge.net/tracker/index.php?func=detail&aid=1486078&group_...

[ 1476816 ] [v0.9.2] java.util.Date parameters

Submitted By: David Lafay - davidlafay
Date Submitted: 2006-04-26 04:15
Last Updated By: teodord - Comment added
Date Last Updated: 2006-07-18 02:00
Number of Comments: 1
Number of Attachments: 0

Assigned To: Nobody/Anonymous
Priority: 5

Summary:
[v0.9.2] java.util.Date parameters

Hi,

I had defined 3 java.util.Date parameters for a report in the JRXML file (with iReport 1.2.1)

I had create a new Report unit on JasperServer. I had defined the 3 parameters with type Date.
When I try to run the report I have ClassCastException

This report was running with 0.9 version. I think version 0.9.2 have a bug with Date parameters.

There is the exception :

org.springframework.webflow.ActionExecutionException:
Exception thrown executing [AnnotatedAction@16bc6e5
targetAction =
com.jaspersoft.jasperserver.war.action.ViewReportAction@cf0d1f,
attributes = mapempty] in state 'verifyData' of
flow 'viewReportFlow'; nested exception is
java.lang.ClassCastException: java.util.Date

There is the trace stack :
org.springframework.webflow.ActionExecutionException:
Exception thrown executing [AnnotatedAction@16bc6e5
targetAction =
com.jaspersoft.jasperserver.war.action.ViewReportAction@cf0d1f,
attributes = mapempty] in state 'verifyData' of
flow 'viewReportFlow'; nested exception is
java.lang.ClassCastException: java.util.Date
java.lang.ClassCastException: java.util.Date at
java.lang.String.compareTo(String.java:90) at
com.jaspersoft.jasperserver.war.action.ViewReportAction.parseRequestValue(ViewReportAction.java:277)
at
com.jaspersoft.jasperserver.war.action.ViewReportAction.parseRequest(ViewReportAction.java:151)
at
com.jaspersoft.jasperserver.war.action.ViewReportAction.verifyData(ViewReportAction.java:87)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method) at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585) at
org.springframework.webflow.util.DispatchMethodInvoker.invoke(DispatchMethodInvoker.java:231)
at
org.springframework.webflow.action.MultiAction.doExecute(MultiAction.java:141)
at
org.springframework.webflow.action.AbstractAction.execute(AbstractAction.java:67)
at
org.springframework.webflow.AnnotatedAction.execute(AnnotatedAction.java:208)
at
org.springframework.webflow.ActionExecutor.execute(ActionExecutor.java:54)
at
org.springframework.webflow.ActionState.doEnter(ActionState.java:184)
at
org.springframework.webflow.State.enter(State.java:201)
at
org.springframework.webflow.Transition.execute(Transition.java:224)
at
org.springframework.webflow.TransitionableState.onEvent(TransitionableState.java:105)
at
org.springframework.webflow.Flow.onEvent(Flow.java:545)
at
org.springframework.webflow.execution.impl.FlowExecutionControlContextImpl.signalEvent(FlowExecutionControlContextImpl.
java:199)
at
org.springframework.webflow.execution.impl.FlowExecutionImpl.signalEvent(FlowExecutionImpl.java:239)
at
org.springframework.webflow.executor.FlowExecutorImpl.signalEvent(FlowExecutorImpl.java:177)
at
org.springframework.webflow.executor.support.FlowRequestHandler.handleFlowRequest(FlowRequestHandler.java:100)
at
org.springframework.webflow.executor.mvc.FlowController.handleRequestInternal(FlowController.java:198)
at
org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:153)
at
org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:45)
at
org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:796)
at
org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:727)
at
org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:396)
at
org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:360)
at
javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
at
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at
com.jaspersoft.jasperserver.war.common.UploadMultipartFilter.doFilter(UploadMultipartFilter.java:83)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:292)
at
org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:116)
at
org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:79)
at
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:303)
at
org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:143)
at
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:303)
at
org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:138)
at
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:303)
at
org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:207)
at
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:303)
at
org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:246)
at
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:303)
at
org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:220)
at
org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:303)
at
org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:173)
at
org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:120)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
at
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
at
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
at java.lang.Thread.run(Thread.java:595)

Followups:

Comments

Date: 2006-07-18 02:00
Sender: teodordProject Admin
Logged In: YES
user_id=332465

Hi,

I think this was caused by a bug in the data type declaration form where min and max values where not set
to null in case the text fields remained empty. This has beed fixed in the meantime and the latest release
should not have this problem anymore. Could you confirm this?

Thank you,
Teodor

Attached Files:
Name Description Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item

tcloonan's picture
1597
Joined: Dec 22 2006 - 1:13am
Last seen: 15 years 5 months ago
Feedback
randomness