[#1357] - Error on creating "Single Select Query" input control

Category:
Bug report
Priority:
Low
Status:
Closed
Project: Severity:
Trivial
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:

Issue migrated from: https://sourceforge.net/tracker/index.php?func=detail&aid=1521390&group_...

[ 1521390 ] Error on creating "Single Select Query" input control

Submitted By: Jean-Francois Levesque - jfworld
Date Submitted: 2006-07-12 12:02
Last Updated By: sgwood - Comment added
Date Last Updated: 2006-07-18 03:08
Number of Comments: 4
Number of Attachments: 0

Assigned To: Nobody/Anonymous
Priority: 5

Summary:
Error on creating "Single Select Query" input control Using: jasperintelligence-1.0.1

When I try to add an input control of type "Single Select Query", I get this error:

org.apache.jasper.JasperException: Exception in JSP:
/WEB-INF/jsp/inputControls/queryDescription.jsp:68

65: <tr>
66: <td colspan="3"><div
align="center"><strong>Please enter Query description
information:</strong></div><BR></td>
67: </tr>
68: <spring:bind
path="control.inputControl.query.name">
69: <tr>
70: <td><div
align="right"><strong>Name:</strong></div></td>
71: <td colspan="2"><input
name="${status.expression}" maxlength="100" type="text"
class="fnormal" size="20" value="<c:out
value='${status.value}'/>"><c:if
test="${status.error!=null}"><BR><span
class="ferror">${status.errorMessage}</span></c:if></td>

Stacktrace:
org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:504)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:393)
(...)

root cause

org.springframework.beans.NullValueInNestedPathException:
Invalid property 'inputControl.query' of bean class
[com.jaspersoft.jasperserver.war.dto.InputControlWrapper]:
Value of nested property 'inputControl.query' is null
org.springframework.beans.BeanWrapperImpl.getNestedBeanWrapper(BeanWrapperImpl.java:397)
org.springframework.beans.BeanWrapperImpl.getBeanWrapperForPropertyPath(BeanWrapperImpl.java:372)
(...)

Followups:

Comments

Date: 2006-07-18 03:08
Sender: sgwoodProject Admin
Logged In: YES
user_id=611753

Did you install from an installer, or the base WAR? What platform: Windows or Linux?

Sherman
JasperSoft

Date: 2006-07-18 02:43
Sender: teodordProject Admin
Logged In: YES
user_id=332465

Hi,

The "Single Select Query" input controls were not meant to work in the 1.0.1 release. It seems that a snapshot taken
from our SVN repository when preparing the installer included partial work that we have done for those input controls
for the future release.

You could either ignore the option in the list for the moment, when defining an input control, or you could try hide it
if you do a build from the source and comment out the option in the com.jaspersoft.jasperserver.war.dto.
InputControlWrapper class.

Thank you,
Teodor

Date: 2006-07-13 05:29
Sender: jfworld
Logged In: YES
user_id=525178

I downloaded jasperintelligence-1.0.1-linux-installer.bin from SF and installed it with bundled Tomcat and MySQL. The "
Single select query" input control is avaiable in the drop down menu when adding a new input control.

Date: 2006-07-13 00:52
Sender: ionutned
Logged In: YES
user_id=1247959

How did you manage to add such an input control? The single select query is not yet available in this release, and the
UI does not allow you to define such input controls.

Ionut

Attached Files:
Name Description Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item

Lucian Chirita: 11/20/2006 9:31 AM PST
Comment:

Query-backed input controls have been introduced in JasperIntelligence 1.1.0.

Regards,
Lucian

Action: Update
Closed set to 11/20/2006
Status changed from Open to Closed

tcloonan's picture
1597
Joined: Dec 22 2006 - 1:13am
Last seen: 15 years 5 months ago
Feedback
randomness