[#1355] - Need to start, stop and start in order for successfull start

Category:
Bug report
Priority:
Low
Status:
Closed
Project: Severity:
Trivial
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

Issue migrated from: https://sourceforge.net/tracker/index.php?func=detail&aid=1522501&group_...

[ 1522501 ] Need to start, stop and start in order for successfull start

Submitted By: Javy Dreamer - javydreamercsw
Date Submitted: 2006-07-14 04:53
Last Updated By: Item Submitter - Tracker Item Submitted
Date Last Updated: No updates since submission
Number of Comments: 0
Number of Attachments: 0

Assigned To: Nobody/Anonymous
Priority: 5

Summary:
Need to start, stop and start in order for successfull start To successfully start JI I need to start the server. But I get this error (part of it since the trace is so long that part is lost from the Tomcat output):

xt(ContextLoader.java:178)
at
org.springframework.web.context.ContextLoaderListener.c
ontextInitiali
zed(ContextLoaderListener.java:49)
at
org.apache.catalina.core.StandardContext.listenerStart
(StandardContex
t.java:3729)
at
org.apache.catalina.core.StandardContext.start
(StandardContext.java:4
183)
at
org.apache.catalina.core.ContainerBase.addChildInternal
(ContainerBase
.java:759)
at
org.apache.catalina.core.ContainerBase.addChild
(ContainerBase.java:73
9)
at
org.apache.catalina.core.StandardHost.addChild
(StandardHost.java:524)

at
org.apache.catalina.startup.HostConfig.deployDirectory
(HostConfig.jav
a:904)
at
org.apache.catalina.startup.HostConfig.deployDirectorie
s(HostConfig.j
ava:867)
at
org.apache.catalina.startup.HostConfig.deployApps
(HostConfig.java:474
)
at org.apache.catalina.startup.HostConfig.start
(HostConfig.java:1112)
at
org.apache.catalina.startup.HostConfig.lifecycleEvent
(HostConfig.java
:310)
at
org.apache.catalina.util.LifecycleSupport.fireLifecycle
Event(Lifecycl
eSupport.java:119)
at org.apache.catalina.core.ContainerBase.start
(ContainerBase.java:1021)

at org.apache.catalina.core.StandardHost.start
(StandardHost.java:718)
at org.apache.catalina.core.ContainerBase.start
(ContainerBase.java:1013)

at
org.apache.catalina.core.StandardEngine.start
(StandardEngine.java:442
)
at
org.apache.catalina.core.StandardService.start
(StandardService.java:4
50)
at
org.apache.catalina.core.StandardServer.start
(StandardServer.java:709
)
at org.apache.catalina.startup.Catalina.start
(Catalina.java:551)
at sun.reflect.NativeMethodAccessorImpl.invoke0
(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.
java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke
(DelegatingMethodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke
(Method.java:585)
at org.apache.catalina.startup.Bootstrap.start
(Bootstrap.java:275)
at org.apache.catalina.startup.Bootstrap.main
(Bootstrap.java:413)

** END NESTED EXCEPTION **

Attempted reconnect 3 times. Giving up.)
at
org.apache.tomcat.dbcp.dbcp.BasicDataSource.createDataS
ource(BasicDat
aSource.java:855)
at
org.apache.tomcat.dbcp.dbcp.BasicDataSource.getConnecti
on(BasicDataSo
urce.java:540)
at
org.springframework.scheduling.quartz.LocalDataSourceJo
bStore$2.getCo
nnection(LocalDataSourceJobStore.java:125)
at
org.quartz.utils.DBConnectionManager.getConnection
(DBConnectionManage
r.java:111)
at
org.quartz.impl.jdbcjobstore.JobStoreCMT.getNonManagedT
XConnection(Jo
bStoreCMT.java:1381)
at
org.quartz.impl.jdbcjobstore.JobStoreCMT.cleanVolatileT
riggerAndJobs(
JobStoreCMT.java:210)
at
org.quartz.impl.jdbcjobstore.JobStoreSupport.initialize
(JobStoreSuppo
rt.java:491)
at
org.quartz.impl.jdbcjobstore.JobStoreCMT.initialize
(JobStoreCMT.java:
144)
at
org.springframework.scheduling.quartz.LocalDataSourceJo
bStore.initial
ize(LocalDataSourceJobStore.java:133)
at
org.quartz.impl.StdSchedulerFactory.instantiate
(StdSchedulerFactory.j
ava:1010)
at
org.quartz.impl.StdSchedulerFactory.getScheduler
(StdSchedulerFactory.
java:1152)
at
org.springframework.scheduling.quartz.SchedulerFactoryB
ean.createSche
duler(SchedulerFactoryBean.java:645)
at
org.springframework.scheduling.quartz.SchedulerFactoryB
ean.afterPrope
rtiesSet(SchedulerFactoryBean.java:546)
at
org.springframework.beans.factory.support.AbstractAutow
ireCapableBean
Factory.invokeInitMethods
(AbstractAutowireCapableBeanFactory.java:860)
at
org.springframework.beans.factory.support.AbstractAutow
ireCapableBean
Factory.initializeBean
(AbstractAutowireCapableBeanFactory.java:829)
at
org.springframework.beans.factory.support.AbstractAutow
ireCapableBean
Factory.createBean
(AbstractAutowireCapableBeanFactory.java:409)
at
org.springframework.beans.factory.support.AbstractBeanF
actory.getBean
(AbstractBeanFactory.java:238)
at
org.springframework.beans.factory.support.AbstractBeanF
actory.getBean
(AbstractBeanFactory.java:148)
at
org.springframework.beans.factory.support.DefaultListab
leBeanFactory.
preInstantiateSingletons
(DefaultListableBeanFactory.java:247)
at
org.springframework.context.support.AbstractApplication
Context.refres
h(AbstractApplicationContext.java:331)
at
org.springframework.web.context.support.AbstractRefresh
ableWebApplica
tionContext.refresh
(AbstractRefreshableWebApplicationContext.java:155)
at
org.springframework.web.context.ContextLoader.createWeb
ApplicationCon
text(ContextLoader.java:240)
at
org.springframework.web.context.ContextLoader.initWebAp
plicationConte
xt(ContextLoader.java:178)
at
org.springframework.web.context.ContextLoaderListener.c
ontextInitiali
zed(ContextLoaderListener.java:49)
at
org.apache.catalina.core.StandardContext.listenerStart
(StandardContex
t.java:3729)
at
org.apache.catalina.core.StandardContext.start
(StandardContext.java:4
183)
at
org.apache.catalina.core.ContainerBase.addChildInternal
(ContainerBase
.java:759)
at
org.apache.catalina.core.ContainerBase.addChild
(ContainerBase.java:73
9)
at
org.apache.catalina.core.StandardHost.addChild
(StandardHost.java:524)

at
org.apache.catalina.startup.HostConfig.deployDirectory
(HostConfig.jav
a:904)
at
org.apache.catalina.startup.HostConfig.deployDirectorie
s(HostConfig.j
ava:867)
at
org.apache.catalina.startup.HostConfig.deployApps
(HostConfig.java:474
)
at org.apache.catalina.startup.HostConfig.start
(HostConfig.java:1112)
at
org.apache.catalina.startup.HostConfig.lifecycleEvent
(HostConfig.java
:310)
at
org.apache.catalina.util.LifecycleSupport.fireLifecycle
Event(Lifecycl
eSupport.java:119)
at org.apache.catalina.core.ContainerBase.start
(ContainerBase.java:1021)

at org.apache.catalina.core.StandardHost.start
(StandardHost.java:718)
at org.apache.catalina.core.ContainerBase.start
(ContainerBase.java:1013)

at
org.apache.catalina.core.StandardEngine.start
(StandardEngine.java:442
)
at
org.apache.catalina.core.StandardService.start
(StandardService.java:4
50)
at
org.apache.catalina.core.StandardServer.start
(StandardServer.java:709
)
at org.apache.catalina.startup.Catalina.start
(Catalina.java:551)
at sun.reflect.NativeMethodAccessorImpl.invoke0
(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.
java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke
(DelegatingMethodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke
(Method.java:585)
at org.apache.catalina.startup.Bootstrap.start
(Bootstrap.java:275)
at org.apache.catalina.startup.Bootstrap.main
(Bootstrap.java:413)
Caused by: java.sql.SQLException: Server connection
failure during transaction.
Due to underlying exception: 'java.sql.SQLException:
Access denied for user 'jas
peradmin'@'localhost' (using password: YES)'.

** BEGIN NESTED EXCEPTION **

java.sql.SQLException
MESSAGE: Access denied for
user 'jasperadmin'@'localhost' (using password: YES)

STACKTRACE:

java.sql.SQLException: Access denied for
user 'jasperadmin'@'localhost' (using p
assword: YES)
at com.mysql.jdbc.MysqlIO.checkErrorPacket
(MysqlIO.java:2928)
at com.mysql.jdbc.MysqlIO.checkErrorPacket
(MysqlIO.java:771)
at com.mysql.jdbc.MysqlIO.secureAuth411
(MysqlIO.java:3649)
at com.mysql.jdbc.MysqlIO.doHandshake
(MysqlIO.java:1176)
at com.mysql.jdbc.Connection.createNewIO
(Connection.java:2683)
at com.mysql.jdbc.Connection.<init>
(Connection.java:1485)
at com.mysql.jdbc.NonRegisteringDriver.connect
(NonRegisteringDriver.java
:266)
at
org.apache.tomcat.dbcp.dbcp.DriverConnectionFactory.cre
ateConnection(
DriverConnectionFactory.java:37)
at
org.apache.tomcat.dbcp.dbcp.PoolableConnectionFactory.m
akeObject(Pool
ableConnectionFactory.java:290)
at
org.apache.tomcat.dbcp.dbcp.BasicDataSource.validateCon
nectionFactory
(BasicDataSource.java:877)
at
org.apache.tomcat.dbcp.dbcp.BasicDataSource.createDataS
ource(BasicDat
aSource.java:851)
at
org.apache.tomcat.dbcp.dbcp.BasicDataSource.getConnecti
on(BasicDataSo
urce.java:540)
at
org.springframework.scheduling.quartz.LocalDataSourceJo
bStore$2.getCo
nnection(LocalDataSourceJobStore.java:125)
at
org.quartz.utils.DBConnectionManager.getConnection
(DBConnectionManage
r.java:111)
at
org.quartz.impl.jdbcjobstore.JobStoreCMT.getNonManagedT
XConnection(Jo
bStoreCMT.java:1381)
at
org.quartz.impl.jdbcjobstore.JobStoreCMT.cleanVolatileT
riggerAndJobs(
JobStoreCMT.java:210)
at
org.quartz.impl.jdbcjobstore.JobStoreSupport.initialize
(JobStoreSuppo
rt.java:491)
at
org.quartz.impl.jdbcjobstore.JobStoreCMT.initialize
(JobStoreCMT.java:
144)
at
org.springframework.scheduling.quartz.LocalDataSourceJo
bStore.initial
ize(LocalDataSourceJobStore.java:133)
at
org.quartz.impl.StdSchedulerFactory.instantiate
(StdSchedulerFactory.j
ava:1010)
at
org.quartz.impl.StdSchedulerFactory.getScheduler
(StdSchedulerFactory.
java:1152)
at
org.springframework.scheduling.quartz.SchedulerFactoryB
ean.createSche
duler(SchedulerFactoryBean.java:645)
at
org.springframework.scheduling.quartz.SchedulerFactoryB
ean.afterPrope
rtiesSet(SchedulerFactoryBean.java:546)
at
org.springframework.beans.factory.support.AbstractAutow
ireCapableBean
Factory.invokeInitMethods
(AbstractAutowireCapableBeanFactory.java:860)
at
org.springframework.beans.factory.support.AbstractAutow
ireCapableBean
Factory.initializeBean
(AbstractAutowireCapableBeanFactory.java:829)
at
org.springframework.beans.factory.support.AbstractAutow
ireCapableBean
Factory.createBean
(AbstractAutowireCapableBeanFactory.java:409)
at
org.springframework.beans.factory.support.AbstractBeanF
actory.getBean
(AbstractBeanFactory.java:238)
at
org.springframework.beans.factory.support.AbstractBeanF
actory.getBean
(AbstractBeanFactory.java:148)
at
org.springframework.beans.factory.support.DefaultListab
leBeanFactory.
preInstantiateSingletons
(DefaultListableBeanFactory.java:247)
at
org.springframework.context.support.AbstractApplication
Context.refres
h(AbstractApplicationContext.java:331)
at
org.springframework.web.context.support.AbstractRefresh
ableWebApplica
tionContext.refresh
(AbstractRefreshableWebApplicationContext.java:155)
at
org.springframework.web.context.ContextLoader.createWeb
ApplicationCon
text(ContextLoader.java:240)
at
org.springframework.web.context.ContextLoader.initWebAp
plicationConte
xt(ContextLoader.java:178)
at
org.springframework.web.context.ContextLoaderListener.c
ontextInitiali
zed(ContextLoaderListener.java:49)
at
org.apache.catalina.core.StandardContext.listenerStart
(StandardContex
t.java:3729)
at
org.apache.catalina.core.StandardContext.start
(StandardContext.java:4
183)
at
org.apache.catalina.core.ContainerBase.addChildInternal
(ContainerBase
.java:759)
at
org.apache.catalina.core.ContainerBase.addChild
(ContainerBase.java:73
9)
at
org.apache.catalina.core.StandardHost.addChild
(StandardHost.java:524)

at
org.apache.catalina.startup.HostConfig.deployDirectory
(HostConfig.jav
a:904)
at
org.apache.catalina.startup.HostConfig.deployDirectorie
s(HostConfig.j
ava:867)
at
org.apache.catalina.startup.HostConfig.deployApps
(HostConfig.java:474
)
at org.apache.catalina.startup.HostConfig.start
(HostConfig.java:1112)
at
org.apache.catalina.startup.HostConfig.lifecycleEvent
(HostConfig.java
:310)
at
org.apache.catalina.util.LifecycleSupport.fireLifecycle
Event(Lifecycl
eSupport.java:119)
at org.apache.catalina.core.ContainerBase.start
(ContainerBase.java:1021)

at org.apache.catalina.core.StandardHost.start
(StandardHost.java:718)
at org.apache.catalina.core.ContainerBase.start
(ContainerBase.java:1013)

at
org.apache.catalina.core.StandardEngine.start
(StandardEngine.java:442
)
at
org.apache.catalina.core.StandardService.start
(StandardService.java:4
50)
at
org.apache.catalina.core.StandardServer.start
(StandardServer.java:709
)
at org.apache.catalina.startup.Catalina.start
(Catalina.java:551)
at sun.reflect.NativeMethodAccessorImpl.invoke0
(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.
java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke
(DelegatingMethodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke
(Method.java:585)
at org.apache.catalina.startup.Bootstrap.start
(Bootstrap.java:275)
at org.apache.catalina.startup.Bootstrap.main
(Bootstrap.java:413)

** END NESTED EXCEPTION **

Attempted reconnect 3 times. Giving up.
at com.mysql.jdbc.Connection.createNewIO
(Connection.java:2749)
at com.mysql.jdbc.Connection.<init>
(Connection.java:1485)
at com.mysql.jdbc.NonRegisteringDriver.connect
(NonRegisteringDriver.java
:266)
at
org.apache.tomcat.dbcp.dbcp.DriverConnectionFactory.cre
ateConnection(
DriverConnectionFactory.java:37)
at
org.apache.tomcat.dbcp.dbcp.PoolableConnectionFactory.m
akeObject(Pool
ableConnectionFactory.java:290)
at
org.apache.tomcat.dbcp.dbcp.BasicDataSource.validateCon
nectionFactory
(BasicDataSource.java:877)
at
org.apache.tomcat.dbcp.dbcp.BasicDataSource.createDataS
ource(BasicDat
aSource.java:851)
... 47 more
Jul 14, 2006 7:48:18 AM
org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Jul 14, 2006 7:48:18 AM
org.apache.catalina.core.StandardContext start
SEVERE: Context [/jasperserver] startup failed due to
previous errors
Jul 14, 2006 7:48:20 AM
org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Jul 14, 2006 7:48:20 AM
org.apache.jk.common.ChannelSocket init
INFO: Port busy 8009 java.net.BindException: Address
already in use: JVM_Bind
Jul 14, 2006 7:48:20 AM
org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8010
Jul 14, 2006 7:48:20 AM org.apache.jk.server.JkMain
start
INFO: Jk running ID=1 time=0/94 config=null
Jul 14, 2006 7:48:20 AM
org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath
resource
Jul 14, 2006 7:48:20 AM
org.apache.catalina.startup.Catalina start
INFO: Server startup in 79905 ms
Jul 14, 2006 7:49:28 AM
org.apache.coyote.http11.Http11BaseProtocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
Jul 14, 2006 7:49:29 AM
org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
Jul 14, 2006 7:49:30 AM
org.apache.coyote.http11.Http11BaseProtocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080
Jul 14, 2006 7:49:30 AM
org.apache.catalina.core.AprLifecycleListener
lifecycleE
vent
INFO: Failed shutdown of Apache Portable Runtime

Some of the last entries are from the attempted server stop which fails. Then I have to close the window and start the
server again. loosk like a mysql tomcat coordination problem. One is starting before than the other.

Followups:

No follow-up comments have been posted.

Attached Files:
Name Description Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item

tcloonan's picture
1222
Joined: Dec 22 2006 - 1:13am
Last seen: 14 years 4 months ago
Feedback