[#1338] - MEP is not yet complete: cannot reset

Category:
Bug report
Priority:
Normal
Status:
Closed
Project: Severity:
Minor
Resolution:
Suspended
Component: Reproducibility:
Always
Assigned to:
0

The attached report runs well on iReport but when attempted from JasperIntelligence produces the following error:

MEP is not yet complete: cannot reset
org.apache.axis2.AxisFault: MEP is not yet complete: cannot reset at org.apache.axis2.description.
OutInAxisOperationClient.reset(OutInAxisOperation.java:377) at com.jaspersoft.jasperserver.irplugin.wsclient.
WSClient.runReport(WSClient.java:493) at com.jaspersoft.jasperserver.irplugin.ReportRunner.run(ReportRunner.
java:66) at java.lang.Thread.run(Unknown Source)

And the stack trace from the server:

10:33:03,804 ERROR [Axis2Servlet],http-8080-Processor23:260 - Servlet.service()
for servlet Axis2Servlet threw exception
org.apache.axiom.om.OMException: Problem with the OutputStream.
at org.apache.axiom.om.impl.MIMEOutputUtils.complete(MIMEOutputUtils.jav
a:62)
at org.apache.axiom.om.impl.MTOMXMLStreamWriter.flush(MTOMXMLStreamWrite
r.java:127)
at org.apache.axiom.om.impl.MTOMXMLStreamWriter.flush(MTOMXMLStreamWrite
r.java:119)
at org.apache.axiom.om.impl.llom.OMNodeImpl.serialize(OMNodeImpl.java:31
1)
at org.apache.axiom.soap.impl.llom.SOAPFaultImpl.internalSerialize(SOAPF
aultImpl.java:214)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerializeAndConsu
me(OMElementImpl.java:809)
at org.apache.axiom.soap.impl.llom.soap11.SOAP11FaultImpl.internalSerial
izeAndConsume(SOAP11FaultImpl.java:79)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerialize(OMEleme
ntImpl.java:780)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerializeAndConsu
me(OMElementImpl.java:809)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerialize(OMEleme
ntImpl.java:780)
at org.apache.axiom.soap.impl.llom.SOAPEnvelopeImpl.internalSerialize(SO
APEnvelopeImpl.java:171)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerializeAndConsu
me(OMElementImpl.java:809)
at org.apache.axiom.om.impl.llom.OMNodeImpl.serializeAndConsume(OMNodeIm
pl.java:381)
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.sendUsingO
utputStream(CommonsHTTPTransportSender.java:256)
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(Com
monsHTTPTransportSender.java:210)
at org.apache.axis2.engine.AxisEngine.sendFault(AxisEngine.java:623)
at org.apache.axis2.transport.http.AxisServlet.handleFault(AxisServlet.j
ava:170)
at org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:1
53)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:252)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:173)
at com.jaspersoft.jasperserver.war.common.UploadMultipartFilter.doFilter
(UploadMultipartFilter.java:83)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:202)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:173)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:264)
at org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(Filt
erSecurityInterceptor.java:107)
at org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(Fi
lterSecurityInterceptor.java:72)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:274)
at com.jaspersoft.jasperserver.api.metadata.user.service.impl.MetadataAu
thenticationProcessingFilter.doFilter(MetadataAuthenticationProcessingFilter.jav
a:137)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:274)
at org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicPr
ocessingFilter.java:181)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:274)
at org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilte
r(HttpSessionContextIntegrationFilter.java:195)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:274)
at org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.jav
a:148)
at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.j
ava:90)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:202)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:173)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
alve.java:213)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
alve.java:178)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
ava:126)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
ava:105)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
ve.java:107)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
a:148)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
:869)
at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.p
rocessConnection(Http11BaseProtocol.java:664)
at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpo
int.java:527)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFol
lowerWorkerThread.java:80)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadP
ool.java:684)
at java.lang.Thread.run(Thread.java:595)
Caused by: ClientAbortException: java.net.SocketException: Software caused conn
ection abort: socket write error
at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffe
r.java:366)
at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:433)
at org.apache.tomcat.util.buf.ByteChunk.append(ByteChunk.java:348)
at org.apache.catalina.connector.OutputBuffer.writeBytes(OutputBuffer.ja
va:392)
at org.apache.catalina.connector.OutputBuffer.write(OutputBuffer.java:38
1)
at org.apache.catalina.connector.CoyoteOutputStream.write(CoyoteOutputSt
ream.java:88)
at org.apache.catalina.connector.CoyoteOutputStream.write(CoyoteOutputSt
ream.java:82)
at org.apache.axiom.om.impl.MIMEOutputUtils.writeMimeBoundary(MIMEOutput
Utils.java:85)
at org.apache.axiom.om.impl.MIMEOutputUtils.startWritingMime(MIMEOutputU
tils.java:95)
at org.apache.axiom.om.impl.MIMEOutputUtils.complete(MIMEOutputUtils.jav
a:39)
... 50 more
Caused by: java.net.SocketException: Software caused connection abort: socket wr
ite error
at java.net.SocketOutputStream.socketWrite0(Native Method)
at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92)
at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
at org.apache.coyote.http11.InternalOutputBuffer.realWriteBytes(Internal
OutputBuffer.java:746)
at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:433)
at org.apache.tomcat.util.buf.ByteChunk.append(ByteChunk.java:348)
at org.apache.coyote.http11.InternalOutputBuffer$OutputStreamOutputBuffe
r.doWrite(InternalOutputBuffer.java:769)
at org.apache.coyote.http11.filters.ChunkedOutputFilter.doWrite(ChunkedO
utputFilter.java:123)
at org.apache.coyote.http11.InternalOutputBuffer.doWrite(InternalOutputB
uffer.java:579)
at org.apache.coyote.Response.doWrite(Response.java:559)
at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffe
r.java:361)
... 59 more
10:34:55,921 ERROR [Axis2Servlet],http-8080-Processor25:260 - Servlet.service()
for servlet Axis2Servlet threw exception
org.apache.axiom.om.OMException: Problem with the OutputStream.
at org.apache.axiom.om.impl.MIMEOutputUtils.complete(MIMEOutputUtils.jav
a:62)
at org.apache.axiom.om.impl.MTOMXMLStreamWriter.flush(MTOMXMLStreamWrite
r.java:127)
at org.apache.axiom.om.impl.MTOMXMLStreamWriter.flush(MTOMXMLStreamWrite
r.java:119)
at org.apache.axiom.om.impl.llom.OMNodeImpl.serialize(OMNodeImpl.java:31
1)
at org.apache.axiom.soap.impl.llom.SOAPFaultImpl.internalSerialize(SOAPF
aultImpl.java:214)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerializeAndConsu
me(OMElementImpl.java:809)
at org.apache.axiom.soap.impl.llom.soap11.SOAP11FaultImpl.internalSerial
izeAndConsume(SOAP11FaultImpl.java:79)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerialize(OMEleme
ntImpl.java:780)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerializeAndConsu
me(OMElementImpl.java:809)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerialize(OMEleme
ntImpl.java:780)
at org.apache.axiom.soap.impl.llom.SOAPEnvelopeImpl.internalSerialize(SO
APEnvelopeImpl.java:171)
at org.apache.axiom.om.impl.llom.OMElementImpl.internalSerializeAndConsu
me(OMElementImpl.java:809)
at org.apache.axiom.om.impl.llom.OMNodeImpl.serializeAndConsume(OMNodeIm
pl.java:381)
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.sendUsingO
utputStream(CommonsHTTPTransportSender.java:256)
at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(Com
monsHTTPTransportSender.java:210)
at org.apache.axis2.engine.AxisEngine.sendFault(AxisEngine.java:623)
at org.apache.axis2.transport.http.AxisServlet.handleFault(AxisServlet.j
ava:170)
at org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:1
53)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:252)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:173)
at com.jaspersoft.jasperserver.war.common.UploadMultipartFilter.doFilter
(UploadMultipartFilter.java:83)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:202)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:173)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:264)
at org.acegisecurity.intercept.web.FilterSecurityInterceptor.invoke(Filt
erSecurityInterceptor.java:107)
at org.acegisecurity.intercept.web.FilterSecurityInterceptor.doFilter(Fi
lterSecurityInterceptor.java:72)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:274)
at com.jaspersoft.jasperserver.api.metadata.user.service.impl.MetadataAu
thenticationProcessingFilter.doFilter(MetadataAuthenticationProcessingFilter.jav
a:137)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:274)
at org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicPr
ocessingFilter.java:181)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:274)
at org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilte
r(HttpSessionContextIntegrationFilter.java:195)
at org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(F
ilterChainProxy.java:274)
at org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.jav
a:148)
at org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.j
ava:90)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
icationFilterChain.java:202)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:173)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
alve.java:213)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
alve.java:178)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
ava:126)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
ava:105)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
ve.java:107)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
a:148)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
:869)
at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.p
rocessConnection(Http11BaseProtocol.java:664)
at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpo
int.java:527)
at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFol
lowerWorkerThread.java:80)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadP
ool.java:684)
at java.lang.Thread.run(Thread.java:595)
Caused by: ClientAbortException: java.net.SocketException: Software caused conn
ection abort: socket write error
at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffe
r.java:366)
at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:433)
at org.apache.tomcat.util.buf.ByteChunk.append(ByteChunk.java:348)
at org.apache.catalina.connector.OutputBuffer.writeBytes(OutputBuffer.ja
va:392)
at org.apache.catalina.connector.OutputBuffer.write(OutputBuffer.java:38
1)
at org.apache.catalina.connector.CoyoteOutputStream.write(CoyoteOutputSt
ream.java:88)
at org.apache.catalina.connector.CoyoteOutputStream.write(CoyoteOutputSt
ream.java:82)
at org.apache.axiom.om.impl.MIMEOutputUtils.writeMimeBoundary(MIMEOutput
Utils.java:85)
at org.apache.axiom.om.impl.MIMEOutputUtils.startWritingMime(MIMEOutputU
tils.java:95)
at org.apache.axiom.om.impl.MIMEOutputUtils.complete(MIMEOutputUtils.jav
a:39)
... 50 more
Caused by: java.net.SocketException: Software caused connection abort: socket wr
ite error
at java.net.SocketOutputStream.socketWrite0(Native Method)
at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92)
at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
at org.apache.coyote.http11.InternalOutputBuffer.realWriteBytes(Internal
OutputBuffer.java:746)
at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:433)
at org.apache.tomcat.util.buf.ByteChunk.append(ByteChunk.java:348)
at org.apache.coyote.http11.InternalOutputBuffer$OutputStreamOutputBuffe
r.doWrite(InternalOutputBuffer.java:769)
at org.apache.coyote.http11.filters.ChunkedOutputFilter.doWrite(ChunkedO
utputFilter.java:123)
at org.apache.coyote.http11.InternalOutputBuffer.doWrite(InternalOutputB
uffer.java:579)
at org.apache.coyote.Response.doWrite(Response.java:559)
at org.apache.catalina.connector.OutputBuffer.realWriteBytes(OutputBuffe
r.java:361)
... 59 more

Javier Ortiz: 10/03/2006 12:00 PM PDT
Comment:

See: http://www.jasperforge.org/index.php?option=com_joomlaboard&Itemid=215&f...

for alike problems in JI 1.1.0

Action: Update
Javier Ortiz: 09/13/2006 7:38 AM PDT
Attachment: Closed_NCR_Aging.jrxml (12.18 KB)
Action: Create
Added an attachment.

AttachmentSize
Binary Data Closed_NCR_Aging.jrxml12.18 KB
tcloonan's picture
1291
Joined: Dec 22 2006 - 1:13am
Last seen: 15 years 1 month ago

1 Comment:

#1

Later versions of JasperServer make this error out of date.

Feedback
randomness