[#1318] - Email notification if report fail

Category:
Feature request
Priority:
Urgent
Status:
Assigned
Project: Severity:
Critical
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:
0

Hi,

It is possible to add email notification function if the report fail to generate?

Even though we can see the 'message' in JS which will display the logs, it would be better send an email.

This can be done in two ways,
1. The email notification will send to JS admin which we will set
2. When we schedule the report, we send a copy to respective recipient via email. If the report fail, the recipient also
will receive an error msg saying 'there was an error occurred during report generation, please contact Admin'

What you guys think about this?
Warmest Regards,
Anandharaj

http://www.jasperforge.org/index.php?option=com_joomlaboard&Itemid=215&f...

tcloonan's picture
1291
Joined: Dec 22 2006 - 1:13am
Last seen: 15 years 4 weeks ago

4 Comments:

#1

In JasperServer 3.0.0, when a report job fails to execute, an email containing the error(s) is sent to the original job notification recipients.

Closing this.

Regards,
Lucian

#2

Hi Lucianc,

Im re-opening this tracker. I would like suggest to enhance this feature. It is not "friendly" to tell the recipient about the error by providing the full error stack.. Perhaps here we can make it a nice customizable message that can send to report recipients.

Beside that, the user with "role_admin" also will receive a email notification with perhaps full error stack.. note: user in "role_admin" is not the actual report recipient.

Looking forward for feedback

#3

Hi,
It would be really useful if we get this functionality soon. Because for me now it has become a major issue which can not be controlled.
Br,
Chamil.

#4

Hi Lucianc;

What happen if we use JasperServer 5.0.
Means, if 'To' email address is not existing, then our report/mail get bounce/failure.
So, in this scenario what will happen.
Does failure/bounce notification mail will sent to 'From' address.

Appreciate your efforts.

Thanks,

S Atah Ahmed Khan..

Feedback