[#13141] - Input Control Option "Always prompt" not working for "In Page" Display Mode

Bug report
Project: Severity:
Component: Reproducibility:
Assigned to:


I tried to update JasperReportsServer from version 7.1.0 to 7.8.0
but I found following issue when I ran my reports on JRS 7.8.0:

My reports have different types of Input Controls (single-select-query, multi-select-query).
I have set the "Always prompt" option in Input Control section (in the report's Controls & Resource section of a report )
and I've chosen the Display Mode = "In Page"

Version 7.1.0 :
- query parameters are asked from user and only after applying parameters report query is executed

Version 7.8.0 :
- query parameters are NOT asked from user.
Report & query are executed immediately after user has chosen report from report list.
It may take a long time before whole report data set is fetched into report with query which has no query parameters set because of the issue in v.7.8.0.
This is a critical issue for our customers who have large data sets.

The issue reproduces also with "Separate page" and "Top of page" display modes.
The issue does not reproduce with "Pop-up window" display mode.

The issue reproduces at least with single-select-query and multi-select-query Input Controls types.

The issue reproduces on Firefox v.81.0.1 , Chrome v.85.0.4183.121, Edge v.85.0.564.68 browser versions.

Please check the attachments.
I have added test reports and export files of those reports from JRS v7.8.0 server.
You can reproduce the issue with those reports & exports files.
The attached reports use the "contacts" table of "sugarcrm" demo database.

Input Controls
harri.penttila's picture
Joined: Dec 9 2014 - 5:15am
Last seen: 5 months 3 days ago


Binary Data 7_8_0_input_test_report.jrxml6.04 KB
Package icon input_test_report_1.zip5.08 KB

Any news? Also occurs on our installation, jusst update from v 7.5 to 7.8 and every Reports submits execution before choosing parameters...
Any workaround?


seems to be fixed but is present in the comulative Hotfix https://support.tibco.com/s/article/TIBCO-JasperReports-Server-v7-8-0-cu...
Only for Commercial version? Version 7.8 community with this bug is unusable...


Is there any workaround for this? I just learned that all my users get an error box after it tries to load, which they must click off before they can enter their parameters.


Is there any work around or solution for this issue?


Any news? I've encountered the same problem upgrading from 7.1 to 7.8 . Thanks


seems we are alone... We are using 7.5 where this issue is note present, but there is also another big issue using cascading parameters...