[#12986] - Jasperserver 7.1.0 -> Client update to Firefox 69.0 and single select query combo opens and closes with no chance to choice

Category:
Bug report
Priority:
High
Status:
New
Project: Severity:
Critical
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
4

Jasperserver 7.1.0 Compilación: 20180504_1307

When client update to Firefox 69.0 x64 Windows 10 PROF x64, single select query combo opens and closes with no chance to choice.

I can see the options but closes too quickly.

It seems javascript error.

This errors happens in old versions of IE like 8.0.

Regards,

Mariano

Input Controls
mlopez_1's picture
975
Joined: Oct 21 2013 - 8:08am
Last seen: 3 weeks 4 days ago

15 Comments:

#1

As per question posted on https://community.jaspersoft.com/questions/1164286/single-select-input-c.... Question also has video that shows the problem.
This seems to be related to version 79, not 69 as mentioned above.
Tested with version 78 and there single select input control works as expected.

This currently affects all our Firefox users, where no single select input control can be used.

Please prioritise a fix for this.

#2

same problem with 7.2 and 7.5 JRS (when controlls are on page start, ...)
NO problem if control is in a separate popup

#3

Sorry for mozilla version, was 79.0 nor 69.0

#4
  • Severity:Major» Critical

Any news about this issue? any workaround?

#5

Also happens in community edition 7.2, 7.8 on Firefox 80.0.1

#6

We are experiencing the same issue. Our customers have complained. We recommend switching to another browser but some of their staff really prefers Firefox. Happened when upgrading to 80.0.1

#7

Drop-down lists still work with Firefox 78.3.0esr. With Google Chrome and Microsoft’s Chrome based Edge it is working too.
Tested with JasperReports Server 7.8.0 Build 20200807_1412.
This should be fixed with high priority because Firefox users can’t choose report parameters anymore.

#8

None find a workaround?

#9

I added the following to the end of my overrides_custom.css:

.jr-mSingleselect-search.jr {
height: auto;
}

This solved the issue for me in 81.0.1.

#10

Hi ANPY
can you pls share the overrides_custom.css
thanks in advance

#11

Hi ANPY, I work with jasperserver 7.1.0 and this ones are my overrides_custom.css files:

jasperserver/themes/pods_summer/overrides_custom.css
jasperserver/themes/easy_access/overrides_custom.css
jasperserver/themes/default/overrides_custom.css
jasperserver/themes/jasper_dark/overrides_custom.css

Have you updated all the files ??

Which is your jasperserver version ??

Regards,

Mariano

#12

I made a copy of jasper_dark theme and added
.jr-mSingleselect-search.jr {
height: auto;
}
to the end of the file themes/jasper_dark_test/overrides_custom.css and tested it with Firefox 82.0 and with jasperserver 7.1 and 7.8. In 7.8 it’s working in 7.1 not.

#13

Hi mlopez_1, I use the jasper_dark theme and added the css to the end of the overrides_custom.css. Jasper Reports Server 7.5.

#14

JRS 7.2: css doesn't help (FF 82, FF 83)
workaround: use popup for input controls

opened another ticket: [#13291]
https://community.jaspersoft.com/jasperreports-server/issues/13291

#15

I know that this post is a little old, but this link (https://community.jaspersoft.com/wiki/firefox-68-having-issue-ad-hoc-dro...) has default_theme_720_js-34685.zip file that it solved for me, both in Firefox, Opera, Chrome and Edge.

Feedback