[#11711] - (almost) fatal error in Jasper Server logs - DiskStorageFactory ERROR

Category:
Bug report
Priority:
High
Status:
Closed
Project: Severity:
Major
Resolution:
Won't Fix
Component: Reproducibility:
Always
Assigned to:
0

I have a report designed in Jasper Studio 6.6.0 published on a 7.1.0 Jasper Server.

For smaller data sets the report is generated ok but for bigger ones I get the following error and the report is not generated:

2019-03-29 00:13:13,331 ERROR DiskStorageFactory,attribute%0043ache.data:495 - Disk Write of com.jaspersoft.jasperserver.api.metadata.user.service.impl.ProfileAttributeCacheKey@d01b42b9 failed:
java.io.NotSerializableException: com.jaspersoft.jasperserver.api.metadata.user.service.impl.ProfileAttributeCacheKey
at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1184)
at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1548)
at java.io.ObjectOutputStream.defaultWriteObject(ObjectOutputStream.java:441)
at net.sf.ehcache.Element.writeObject(Element.java:835)
at sun.reflect.GeneratedMethodAccessor284.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at java.io.ObjectStreamClass.invokeWriteObject(ObjectStreamClass.java:1128)
at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1496)
at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1432)
at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1178)
at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:348)
at net.sf.ehcache.util.MemoryEfficientByteArrayOutputStream.serialize(MemoryEfficientByteArrayOutputStream.java:97)
at net.sf.ehcache.store.disk.DiskStorageFactory.serializeElement(DiskStorageFactory.java:405)
at net.sf.ehcache.store.disk.DiskStorageFactory.write(DiskStorageFactory.java:384)
at net.sf.ehcache.store.disk.DiskStorageFactory$DiskWriteTask.call(DiskStorageFactory.java:485)
at net.sf.ehcache.store.disk.DiskStorageFactory$PersistentDiskWriteTask.call(DiskStorageFactory.java:1088)
at net.sf.ehcache.store.disk.DiskStorageFactory$PersistentDiskWriteTask.call(DiskStorageFactory.java:1072)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

Once I get this error a few times even the reports worked before will stop working.

PS: somebody else posted same issue at com.jaspersoft.jasperserver.api.metadata.user.service.impl.ProfileAttributeCacheKey

Thanks,

v7.1.0
mihai.bucica's picture
Joined: Mar 28 2019 - 4:42pm
Last seen: 2 years 2 weeks ago

3 Comments:

#1
  • Resolution:Open» Won't Fix
  • Status:New» Closed

Please post questions to the Answers forum instead of here.
This usually happens when you don't have enough memory and jvm is thrashing.

#2

hi, could you solve the problem? can share

#3

java.io.NotSerializableException can occur when you serialize an inner class instance because serializing such an inner class instance will result in serialization of its associated outer class instance as well. How to solve it?

If the class is yours, make the class serializable by implementing the interface java.io.Serializable.
All non primitive members implement Serializable (or are transient instead)
If your class is an inner class it's either static or the outer class implements Serializable
If the class is 3rd party, but you don't need it in the serialized form, mark the field as transient

It is important to note that Serialization of inner classes (i.e., nested classes that are not static member classes), including local and anonymous classes, is strongly discouraged.

http://net-informations.com/java/cjava/default.htm

Feedback