[#10556] - jasperreport 6.4 No define call for cv-component

Category:
Bug report
Priority:
High
Status:
New
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

Hello,

I did install jasperserver 6.4 community edition via bundle. 

When I deploy a report with custom component (highchart) on the server. It run into a loop.

Checking into the browser console, I got this error:

Uncaught Error: No define call for cv-component
http://requirejs.org/docs/errors.html#nodefine
at makeError (require.js:1)
at Object.completeLoad (require.js:1)
at HTMLScriptElement.onScriptLoad (require.js:1)

I have checked the reference to phantomjs and require.js and it looks that the bundle install set them well:
/opt/jasperreports-server-cp-6.4.2/apache-tomcat/webapps/jasperserver/WEB-INF/classes/jasperreports.properties

net.sf.jasperreports.phantomjs.executable.path=/opt/jasperreports-server-cp-6.4.2/phantomjs/bin/phantomjs
com.jaspersoft.jasperreports.components.customvisualization.phantomjs.executable.path=/opt/jasperreports-server-cp-6.4.2/phantomjs/bin/phantomjs
net.sf.jasperreports.web.resource.pattern.customvisualization.scripts=com/jaspersoft/jasperreports/customvisualization/resources/require
com.jaspersoft.jasperreports.components.customvisualization.require.js=file:////opt/jasperreports-server-cp-6.4.2/apache-tomcat/webapps/jasperserver/optimized-scripts/bower_components/requirejs/require.js

Could you please help

Thanks

degroodt.nicolas's picture
Joined: Jan 6 2014 - 7:02am
Last seen: 4 days 14 hours ago

1 Comment:

#1
  • Priority:Normal» High
  • Severity:Minor» Major
  • Reproducibility:N/A» Always
Feedback
randomness