[#8401] - Last Page Footer ignores PrintWhenExpression?

Category:
Bug report
Priority:
Low
Status:
Closed
Project: Severity:
Minor
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
0

Replicate

1. Create a report that has a page footer (1 page) and a summary (1 page)
2. Add a Last Page Footer band
3. Set the PrintWhenExpression for Last Page Footer band to: Boolean.FALSE
4. Run the report

Expected Results

Two pages (the report and the summary).

Actual Results

Three pages (report, summary, and last page footer page).

Work Around

Use a Detail band instead of Last Page Footer band.

v6.3
thangalin's picture
359
Joined: Apr 21 2008 - 4:34am
Last seen: 2 days 18 hours ago

3 Comments:

#1
  • Status:New» Feedback Requested
  • Assigned:nobody» teodord

Hi,

I was not able to reproduce this. Maybe there is some more property that needs to be set, or I did not make the sections the correct size to reproduce this. I always obtained only two pages.
Please upload here a JRXML, if you still see this problem.

Thank you,
Teodor

#2
  • Resolution:Open» Unable to Reproduce
  • Status:Feedback Requested» Resolved
#3
  • Status:Resolved» Closed

Probably has been fixed.

Feedback
randomness