[#3489] - Can't generate PDF/A-1

Category:
Bug report
Priority:
Normal
Status:
New
Project: Severity:
Minor
Resolution:
Open
Component: Reproducibility:
N/A
Assigned to:

As I didn't get any hints on what I could have done wrong for two weeks, I suppose that my PDF/A-1 issue is not caused by a problem on my side. This ways, I'll raise my question to a bug now. Please see my question for details:

http://community.jaspersoft.com/questions/824374/cant-generate-pdfa-1

v5.5.1
The Dentist's picture
Joined: Jan 31 2014 - 11:28am
Last seen: 3 years 7 months ago

3 Comments:

#1
  • Assigned:nobody»

After having spend a lot of time on this matter, we have found out how to get PDF/A-1a working with our application. There are some things to do that are not mentioned in the howto that I had linked in my question:
1. You'll need to embed your fonts in your pdf. In Jaspersoft Studio, make sure that the fonts are listed in the corresponding menu of your projects properties (don't confuse with your reports properties). From that menu, you should be able to export the fonts as jar, which you should include in your build path to embed the fonts within your java application. I also set the net.sf.jasperreports.default.pdf.embedded property to true, although that may not be necessary.
2. Make sure you have a default style. To do so, open the styles section of your report and select the style you'd like to make default or open your style template if you use one and select the font there. Then, under advanced set default to true. If you had no style in your report so far, add one by right-clicking on the styles entry and find your way through the menus. You'll be able to refer to an existing style template as well.

Additional hint: when trying to set up a PDF/A-1a document for the first time, make sure you use an image format that does not know transpareny (like jpeg) and don't use "one empty record" as datasource, but set up some datasource yourself (seems like with "one empty record", Jaspersoft Studio will show a page on the preview, but won't eport to pdf anything). Maybe png without transparency will work, too (haven't tried yet), and the datasource is independant from pdf/a technically, these things may help limiting the sources of errors.

As of now, I was able to get it to work with my client application only. I had no luck to export pdf/a-1a from Jaspersoft Studio so far.

Having said all this, I'd like to suggest to extend the linked howto with my two points above. As it is now, the howto won't lead to any success, at least not for newcomers.

#2
  • Assigned:» anonymous

Dentist,

While I don't know enough to address your issue, I've posted your points to the Wiki page in question: http://community.jaspersoft.com/wiki/pdf-support-jasperreports-library . Surely your issue will be addressed at some point.

Thanks for your efforts and,

Good luck

#3

Well, my issue is pretty much solved with this. It turned out that there was no technical bug, the guide was just incomplete. The only - but minor - point is that I still can't export PDF/A-1 from within Jaspersoft Studio. I have found the pdf exporter settings in the meantime (in the project properties) and can export pdf, but it doesn't seems to be a PDF/A. Well, anyways, as long as I can export it from my java application. Although the whole process could be a bit more handy (PDF/A should be treated as separate format IMO). Anyways, thank you for extending the guide! This ways, the whole search was of some use at least.

Feedback
randomness