[#2965] - Serialization error while printing Barbecue EAN128 barcode

Category:
Bug report
Priority:
High
Status:
Resolved
Project: Severity:
Minor
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
0

If a Jasper Report template uses a Barbecue EAN128 type Barcode, if an attempt is made to print it using the JRPrintExporter, an exception is generated due to a serialization error on the CharBuffer class.

For reference, see: http://barbecue.sourceforge.net/apidocs/net/sourceforge/barbecue/linear/... which shows that the actual Code128Barcode implements a Serializable interface, while the CharBuffer does not. The core of the issue here is that the report is attempting to serialize the CharBuffer object, which fails.

v5.1.0
stevep0000's picture
Joined: Sep 30 2010 - 6:56am
Last seen: 1 year 1 week ago

3 Comments:

#1
  • Assigned:nobody» shertage
#2
  • Resolution:Open» Unable to Reproduce
  • Status:New» Feedback Requested

Hi,
Could you post a sample report here in order to help us reproduce the problem? With our current sample barbecue report it cannot be reproduced.

Thanks.

#3
  • Status:Feedback Requested» Resolved

Feel free to reopen this if you can provide more details and can help us reproduce it.

Thanks,
Teodor

Feedback