[#2594] - Error POM for com.lowagie:itext:jar: 2.1.7.js1

Category:
Bug report
Priority:
High
Status:
Closed
Project: Severity:
Critical
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:
1

The POM for com.lowagie:itext:jar:2.1.7.js1 is missing, no dependency information available.

<dependency>
<groupId>com.lowagie</groupId>
<artifactId>itext</artifactId>
<version>2.1.7.js1</version>
<scope>compile</scope>
</dependency>

Invalid Version, this version does not exist.

The correct version is: 2.1.7 only.

v4.8.0
leandro.freitas's picture
Joined: Nov 15 2012 - 1:16pm
Last seen: 6 years 5 months ago

12 Comments:

#1
  • Assigned:nobody» teodord

Assigned to teodord.

#2
  • Status:New» Feedback Requested

Hi,

We have patched the iText 2.1.7 to solve a transparency bug. We've published the patched iText version on our public Maven repository at:
http://jasperreports.sourceforge.net/maven2/com/lowagie/itext/2.1.7.js1/

If you look at the pom.xml in JR, you can see we refernce this repository there.

What did you try to do and did not work? What was the error?

Thanks,
Teodor

#3

The error happens when compiling my project in netbeans sync with Nexus Maven.
I use Nexus as a repository and I'm pointing to the Central Maven which did not find a dependence.

I'll put this on my new nexus repository and test.

Thank you.

#4

I added the url on my Nexus and referenced correctly.

Thanks.

#5
  • Resolution:Open» No Change Required
  • Status:Feedback Requested» Resolved
#6
  • Status:Resolved» Closed
#7

Can You describe how to do it?

#8

To do this you need to have the Nexus Maven configured.
Then do the same in the example image.

AttachmentSize
Image icon jasper_report_config_nexus.jpg186.67 KB
#9

Thx for screen but my maven on local station still cat see it, any special Access Settings? I can browse remote repo. from nexus.

#10
  • Priority:Normal» High
  • Severity:Minor» Critical

I changed name of my jasperReport jar from jasperreports-6.1.0.jar to jasperreports-6.1.0-modified.jar due to some reason and then built my war.
It was unable to download itext jar that is dependent. What is the reason for that ?

#11
  • Status:Closed» New
#12
  • Status:New» Closed

Hi,

Maybe the problems you experienced on August 14, 2015 were caused by some Sourceforge.net outage which affected them for a few weeks in late July and early August.

Try again and let us know.

Thanks,
Teodor

Feedback
randomness