[#2468] - Styled Text Bullet List without in indentation

Category:
Bug report
Priority:
High
Status:
Assigned
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
138

The second and following lines of a bullet list entry which word-wrapped over multiple lines does not get indented like it would do in html using the <UL>,</UL> token.

Holger's picture
4
Joined: Nov 16 2006 - 7:06pm
Last seen: 6 months 3 weeks ago

22 Comments:

#1

Hi again!

We still have the same problems that multiple lines for one list item are still without indention at second(followed) lines.

I just tried within JasperReports 3.1.4 but it's still the same.
Could anybody help us to correct the line indention if the text will stretch over several lines.

tia
C-Box

#2

Hi Teodor,

I just read the announce to 3.5.0 and I want to know if the indentation problem is also solved with the new support for ordered lists!?!??!?!?!?!?

tia + regards from sunny Germany
C-Box

#3

Hi, C-Box

Unfortunately, not. We are not dealing with layout at all in our text fields. This is not trivial, and not sure when we'll get a chance to do something about it. Let's keep this open for now.

Thanks,
Teodor

#4

I have developed a patch that enables indentation (and also tables). I am willing to contribute this. If you are interested, just let me know.

Solution idea: I am replacing a single text field by a frame containing a number of text fields (or even more frames) on the fly. Indentation is achieved by moving the inner text fields a bit to the right and making them narrower at the same time. The solution has been tested thoroughly to make sure the replacement behaves exactly like an original text field (page breaks, padding, print when overflows, etc.).

Regards,
-Guido

#5

Hi,

Please post your patch as a separate tracker here.
Chose category "Patches" for the tracker and make sure you attach the patch file.

We'll take it from there.

Thank you,
Teodor

#6

Another possible solution would be to apply a negative first line indent, and a postive overall left indent. This is actually recommended practice for some other tools (e.g. Scribus).

This doesn't work because the negative first indent is wrongly interpreted as being a right indent. I can't imagine the use of that (although that doesn't mean that someone hasn't done it).

So a simple solution that doesn't involve re-writing a layout engine would be to provide a separate first line right indent attribute and allow proper negative numbers in the firstlineindent.

#7

hello,

what about this Problem? I imangined that aswell and it looks crappy :)
It was Targeted to Version 4.1.1. Is there any news about the status?

Cheers,
Damian

#8

Any update on this? Is it actually being worked on?

#9

I saw that the new 4.6 version has been released... Does the new version contain the fix for that bug?

#10

Negative first line indent would be a great solution.

#11

Seems this is never going to be fixed despite the obvious need.

#12

Would be great if this would be fixed: I just ran into this very same issue when trying to pass some bulleted list of Strings as HTML to a styled text field with JR 5.0.1.
In the meantime, any recommendations on alternative solutions to have multiple bulleted Strings without resorting to a full subreport would be much appreciated as well.

#13

It's pretty ridiculous that this has been a problem for a number of years and it would probably be such an easy fix, but it still hasn't been done. Anyone have a workaround they would like to share?

Thanks.

#14
  • Priority:Immediate» Urgent
  • Severity:Block» Major

Hi, is solved? . I'm using jasperreports-5.2.0.jar but the problem persist with the indentation for the large text in li tag.
Thanks for any support or information.

#15

Maybe 2015 will do it ;-)

#16

Please fix

#17

Still nog plans to fix this? Would be great and a plus in the layout!

#18
  • Severity:Major» Critical

We are desperately waiting for this to be fixed. Our customers are getting upset...

#19
  • Priority:Urgent» High
  • Severity:Critical» Major

Are there any updates on this issue?

#20

This is absolutely critical for me. My client has rejected all letters produced with Jasper reports which have bulletted lists, and there are quite a few. I am now looking at using a tool other than Jasper because of this (to me) minor issue.

#21

Is there a solution to this? Also very critical here for our users. Styled text is not being styled properly as <li></li> elements should be.

#22

Hi Teodord, Is there any updates on this issue?

Feedback