[#13611] - Jasper report is having compatibility with latest POI 5.0.0

Category:
Bug report
Priority:
Urgent
Status:
New
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
1

Hello Team,

During POI 5.0.0 upgrade, having compatibility issue with the jasper report version 6.12.0. POI has changed one of the method return type from short to Int causing compile time issue on our components. Please advice.

Compile time error

java.lang.NoSuchMethodError: org.apache.poi.hssf.usermodel.HSSFFont.getIndex()S
at

Thanks,
M.subrahmanyam.

v6.12
jasper library
subbu.mca36's picture
Joined: Apr 3 2019 - 2:43am
Last seen: 3 months 2 weeks ago

1 Comment:

#1

Same here. Need to update poi due to security issues inside the dependent commons-compress.
POI updated the dependency in 5.0.0, so there it would be fixed, but can't upgrade due to that compatibility issue!
Please update your dependency to POI too!
The CVE's are:
CVE-2021-35515, CVE-2021-35516, CVE-2021-35517, CVE-2021-36090

Feedback