[#13161] - Export to TXT results in extra blank lines within report

Category:
Bug report
Priority:
High
Status:
Feedback Requested
Project: Severity:
Major
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:
0

I am attempting to create a report for end of year IRS reporting. Report needs to conform to IRS guidelines and is a txt file in a precise format. I have followed the guidance for creating such a report (https://github.com/TIBCOSoftware/jasperreports/blob/master/jasperreports...). I am using the dejavu mono font with the but I have been unable to produce a report that does not contain intermittent blank lines. My detail literally has no fields on it - only a blank line of the appropriate length and I still get extra blank lines (report should only have 1447 detail lines but I always get 1452 no matter what i try). I have pared the report down to just a blank line for each detail and still cannot get it to produce the correct number of detail lines.

AttachmentSize
Binary Data 1009k_tax_information6.jrxml3.38 KB
v6.4.2
Jaspersoft® Studio
bogartlisa's picture
Joined: Mar 14 2013 - 1:20pm
Last seen: 4 days 15 hours ago

6 Comments:

#1
  • Assigned:nobody» ameyers@tibco.com
#2

Not sure the workflow on these kind of issues but it does seem odd that I can assign the issue to someone? I have gotten no feedback since posting so maybe this will help???

#3
  • Resolution:Open» No Change Required
  • Status:New» Resolved
  • Assigned:ameyers@tibco.com» chicuslavic

There is a property http://jasperreports.sourceforge.net/config.reference.html#net.sf.jasper...

try to setup this property and see if it is what you want.
This question is actually for the JasperReports library not for Jaspersoft Studio.

#4
  • Status:Resolved» Feedback Requested

I have that property set (<property name="net.sf.jasperreports.export.text.page.separator" value=""/>). Does not correct the problem.

#5
  • Status:Feedback Requested» Resolved
#6
  • Status:Resolved» Feedback Requested
Feedback
randomness