[#12866] - com/lowagie/itext/2.1.7.js7 no more available on mvnrepository (has been moved)

Category:
Bug report
Priority:
High
Status:
Resolved
Project: Severity:
Block
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:

Blocker issue. https://mvnrepository.com/artifact/net.sf.jasperreports/jasperreports/6.... or latest 6.13.0 are no more usable as it due to a reference to http://www.mvnrepository.com/com/lowagie/itext/2.1.7.js7/itext-2.1.7.js7... that have been removed/moved from mvncentral.

Here is the error that I get:
Failed to collect dependencies at net.sf.jasperreports:jasperreports:jar:6.11.0 -> com.lowagie:itext:jar:2.1.7.js7: Failed to read artifact descriptor for com.lowagie:itext:jar:2.1.7.js7: Could not transfer artifact com.lowagie:itext:pom:2.1.7.js7 from/to mvnrepository (http://www.mvnrepository.com): Failed to transfer file http://www.mvnrepository.com/com/lowagie/itext/2.1.7.js7/itext-2.1.7.js7... with status code 308 -> [Help 1]

The new lowagie/itext repo seems to be this one: https://mvnrepository.com/artifact/com.lowagie/itext

Thanks for your support.

v6.11
thibault.duez's picture
Joined: Jul 1 2020 - 7:54am
Last seen: 1 year 10 months ago

7 Comments:

#1

My build just succeed to download it via your third-party repository. But I think the original issue could even be fixed.

12812 [INFO] Downloading from mvnrepository: http://www.mvnrepository.com/com/lowagie/itext/2.1.7.js7/itext-2.1.7.js7...
13543 [INFO] Downloading from central: https://repo.maven.apache.org/maven2/com/lowagie/itext/2.1.7.js7/itext-2...
13884 [INFO] Downloading from jaspersoft-third-party: http://jaspersoft.jfrog.io/jaspersoft/third-party-ce-artifacts/com/lowag...
14418 [INFO] Downloaded from jaspersoft-third-party: http://jaspersoft.jfrog.io/jaspersoft/third-party-ce-artifacts/com/lowag... (3.1 kB at 5.7 kB/s)

#2

itext 2 is not maintained any more.

There is a drop-in replacement: https://github.com/LibrePDF/OpenPDF

Please upgrade Jasperreports to OpenPDF

#3
  • Priority:Immediate» High

I ran against the same problem this week.
After investigating the maven central repo and the ICM repo http://maven.icm.edu.pl/artifactory/repo/ i came to the conclusion the dependency is no more available until finding this issue and the provided solution.

Now i see the state of this issue is 'open' and marked 'blocking'since 01/06/2020 without any response from the maintainers.
How is this not blocking for any others?

@thibault.duez i'm wondering how you found out it has been moved to the jaspersoft repo.
And is there documentation about this (or do we just have to search ourselves)?

@keesvandieren also makes a good point. Notifying the dependency in question is really outdated.
Even no more maintained. is there an action plan?

#4

iText 2.1.7.js7 is available at http://jaspersoft.jfrog.io/jaspersoft/third-party-ce-artifacts/

You'll need to add that repository to your project.

See https://github.com/TIBCOSoftware/jasperreports/issues/148 and https://github.com/TIBCOSoftware/jasperreports/issues/109 for some discussion on this.

Regards,
Lucian

#5

Thanks for the update. We have added the repository and i will try to upgrade jasper reports to the latest version.

#6

Same blocker issue with latest 6.20.0 version of jasperreports which is not useable from the maven repo, eg https://repo1.maven.org/maven2/net/sf/jasperreports/jasperreports/6.20.0... contains a reference to version 2.1.7.js10 as below, which doesn't exist in https://repo1.maven.org/maven2/com/lowagie/itext/

<dependency>
<groupId>com.lowagie</groupId>
<artifactId>itext</artifactId>
<version>2.1.7.js10</version>

Error seen:

Could not resolve dependencies for project ...: Could not find artifact com.lowagie:itext:jar:2.1.7.js10

#7
  • Resolution:Open» No Change Required
  • Status:New» Resolved
  • Assigned:nobody» teodord

David,

The answer was already provided at reply #4 above. Not everything is supposed to be on repo1.maven.org. This is why Maven allows by design to add other repositories, and we did.

Thank you,
Teodor

Feedback
randomness