[#12796] - Jasperstudio Professional / Community library compatibility

Category:
General
Priority:
Normal
Status:
Feedback Requested
Project: Severity:
Minor
Resolution:
Open
Component: Reproducibility:
N/A
Assigned to:
0

HI Team,

we currently have Jaspersoft Studio Professional version 7.3.0.final in use with the JasperReports Library version 6.8.1.

Which community version can be used in parallel with the professional version 7.3.0 so that there are no conflicts?

Thanks in advance

Joachim

jla_2's picture
2
Joined: Sep 18 2019 - 1:53am
Last seen: 5 months 1 week ago

1 Comment:

#1
  • Status:New» Feedback Requested
  • Assigned:nobody» teodord

Hi,

The Professional versions of JRL and JSS are no longer in sync with the Community Editions (open source) versions in terms of exact same numbers.
The CE products remained at 6.*, while the Pro variants are now at 7.*.

You should use the JRL CE library version that is shipped with your JSS Pro product. Note that you can also use older versions of the library in production, as long as you make sure the reports you design are saved in the proper/compatible version using the preference page in JSS where you can indicate older versions of the library, for backwards compatibility.

I hope this helps.
Teodor

Feedback
randomness