[#12446] - XSD not compliant / missing textAdjust Property (Jasper 6.11.0)

Category:
Bug report
Priority:
Normal
Status:
Confirmed
Project: Severity:
Major
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:
0

Hello,

with Jasper 6.11.0 came a new textAdjust property for text field elements. Unfortunately this element is not contained in http://jasperreports.sourceforge.net/xsd/jasperreport.xsd and therefore these reports are not compiling with external builders (maven) any longer.

As Jasper automatically converts the old stretch with overflow to the new textAdjust element we´re not able to edit any report with Jasper 6.11.0.

Seems like this happened already in the past:
https://community.jaspersoft.com/jasperreports-library/issues/4401-0

Please fix!

Regards

v6.11
kw-001's picture
2
Joined: Dec 20 2019 - 1:29am
Last seen: 6 months 4 weeks ago

16 Comments:

#1
  • Status:New» Feedback Requested
  • Assigned:nobody» teodord

Hi,

Can you explain in more detail how you compile your reports?
I agree that the public XSD was not updated, and we'll do that shortly, but JasperReports report compiler does not actually load it from that public location. It as an internal copy in the JAR and that one gets used.
So I don't understand why you get report compilation errors, if you compile with JRL 6.11.0.

Thank you,
Teodor

#2

We use the maven plugin below for building/compiling our jasper report files.

<plugin>
<groupId>com.alexnederlof</groupId>
<artifactId>jasperreports-plugin</artifactId>
<version>2.3</version>
<dependencies>
<!--note this must be repeated here to pick up correct xml validation -->
<dependency>
<groupId>net.sf.jasperreports</groupId>
<artifactId>jasperreports</artifactId>
<version>${jasper.version}</version>
</dependency>
</dependencies>
<executions>
<execution>
<phase>compile</phase>
<goals>
<goal>jasper</goal>
</goals>
</execution>
</executions>
<configuration>
<!-- These are the default configurations: -->
<compiler>net.sf.jasperreports.engine.design.JRJdtCompiler</compiler>
<sourceDirectory>src/main/resources/forms</sourceDirectory>
<outputDirectory>target/classes/forms</outputDirectory>
<verbose>false</verbose>
</configuration>
</plugin>

This plugins seems to use http://jasperreports.sourceforge.net/xsd/jasperreport.xsd for validating the xml structure.

[ERROR] Could not compile Foe.jrxml because org.xml.sax.SAXParseException; lineNumber: 56; columnNumber: 69; cvc-complex-type.3.2.2: Attribut 'textAdjust' darf nicht in Element 'textField' vorkommen.
net.sf.jasperreports.engine.JRException: org.xml.sax.SAXParseException; lineNumber: 56; columnNumber: 69; cvc-complex-type.3.2.2: Attribut 'textAdjust' darf nicht in Element 'textField' vorkommen.
at net.sf.jasperreports.engine.xml.JRXmlLoader.loadXML(JRXmlLoader.java:302)
at net.sf.jasperreports.engine.xml.JRXmlLoader.loadXML(JRXmlLoader.java:285)
at net.sf.jasperreports.engine.xml.JRXmlLoader.load(JRXmlLoader.java:274)
at net.sf.jasperreports.engine.xml.JRXmlLoader.load(JRXmlLoader.java:248)
at net.sf.jasperreports.engine.JasperCompileManager.compileToStream(JasperCompileManager.java:307)
at net.sf.jasperreports.engine.JasperCompileManager.compileReportToStream(JasperCompileManager.java:587)
at com.alexnederlof.jasperreport.CompileTask.call(CompileTask.java:63)
at com.alexnederlof.jasperreport.CompileTask.call(CompileTask.java:28)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

#3

Hi,

We don't know how this plugin works, but when looking into its pom.xml, we see it uses JRL 6.9.0.
https://repo1.maven.org/maven2/com/alexnederlof/jasperreports-plugin/2.6...

Maybe there is a way to tell the plugin to use the latest JRL 6.11.0, where the XSD contains the field.
In any case, I don't think this is related to the XSD we have on the website.

Thanks,
Teodor

#4

You have this

<dependency>
<groupId>net.sf.jasperreports</groupId>
<artifactId>jasperreports</artifactId>
<version>${jasper.version}</version>
</dependency>

Could you share the value of the jasper.version property?

Regards,
Lucian

#5
  • Assigned:nobody»

While not a direct fix, I found that by switching the Text Adjust property to CutText, it allowed me to run the report without errors.

#6
  • Resolution:Open» No Change Required
  • Status:Feedback Requested» Resolved
  • Assigned:nobody» teodord

Steven,

I'm not sure what was the error you had and how this was solved by setting the textAdjust property. The deprecated property isStretchWithOverflow should still work with the latest version of the library.
If the textAdjust was not recognized by an older JRL used, then even setting it to CutText would not help.
In any case, I just wanted to suggest that you could use an Ant task to update all your JRXMLs to the latest syntax as shown in the /demo/samples/antupdate sample shipped with the JRL project:
https://github.com/TIBCOSoftware/jasperreports/tree/master/jasperreports...
documented here:
http://jasperreports.sourceforge.net/sample.reference/antupdate/index.ht...

Konstanz,

Feel free to reopen this if you can provide more details about the actual version of JRL that you use with the Maven plugin.

Thank you,
Teodor

#7

@Lucian
Your guess was right we had 6.4.x in jasper.version. I set it up to the newest version and now the xsd is used from the internal package. Everything works now.

Thanks for your help!!

#8
  • Resolution:No Change Required» Reopened
  • Status:Resolved» Feedback Requested
  • Assigned:nobody»

Hi Guys,
I am running Talend job calling JasperReports .jrxml template. I am having the error as below.

Save jasper file C:\FWR/summary_opsreport_2_n.jasper
[ERROR]: org.apache.commons.digester.Digester - Parse Error at line 45 column 83: cvc-complex-type.3.2.2: Attribute 'textAdjust' is not allowed to appear in element 'textField'.
org.xml.sax.SAXParseException; lineNumber: 45; columnNumber: 83; cvc-complex-type.3.2.2: Attribute 'textAdjust' is not allowed to appear in element 'textField'.
at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(Unknown Source)
at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.error(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator$XSIErrorReporter.reportError(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.reportSchemaError(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.processAttributes(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.handleStartElement(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.xs.XMLSchemaValidator.startElement(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(Unknown Source)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
at org.apache.commons.digester.Digester.parse(Digester.java:1892)
at net.sf.jasperreports.engine.xml.JRXmlLoader.loadXML(JRXmlLoader.java:298)
at de.jlo.talendcomp.jasperreportexec.JasperReportExecuter.retrieveJasperDesign(JasperReportExecuter.java:389)
at de.jlo.talendcomp.jasperreportexec.JasperReportExecuter.compileReport(JasperReportExecuter.java:411)
at de.jlo.talendcomp.jasperreportexec.JasperReportExecuter.compileReport(JasperReportExecuter.java:522)
at de.jlo.talendcomp.jasperreportexec.JasperReportExecuter.compileReport(JasperReportExecuter.java:355)
at fwr_besara5testing.jloadfwr_0_1.jLoadFWR.tJasperReportExec_2Process(jLoadFWR.java:378)
at fwr_besara5testing.jloadfwr_0_1.jLoadFWR.runJobInTOS(jLoadFWR.java:768)
at fwr_besara5testing.jloadfwr_0_1.jLoadFWR.main(jLoadFWR.java:603)

The pdf file won't be created due to this error.
Please advice. TIBCO JasperReports is 6.11.0 and my jar files are all the latest version.
I have include the path to the jar library in Talend and JasperReport Build Path as well.
Please, please advice.

TQ

#9
  • Assigned:nobody» teodord

Fauzah,

The version of the JasperReports Library in the Talend plugin you are using is not the latest.
If you are using Jaspersoft Studio to design your report, it has an option in the Preferences/Jaspersoft Studio/Compatibility to set a previous version of JRXML format to save your file.

I hope this helps.
Teodor

#10
  • Assigned:nobody»

Here's the workflow that led to this error, after upgrading to ver 6.11

1. Opened a report hosted in a jasper server made in a previous version and made amendments. Runs ok on preview in Jaspersoft Studio. When saving to server I get this error and cannot preview the report on the server

org.apache.http.client.HttpResponseException: illegal.parameter.value.error
Invalid JRXML
JRXML.content
JRXML.content
at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleErrorDescriptor(RESTv2ExceptionHandler.java:121)
at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleException(RESTv2ExceptionHandler.java:61)
at com.jaspersoft.studio.server.protocol.restv2.ARestV2ConnectionJersey.toObj(ARestV2ConnectionJersey.java:49)
at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.addOrModifyResource(RestV2ConnectionJersey.java:631)
at com.jaspersoft.studio.server.protocol.ProxyConnection.addOrModifyResource(ProxyConnection.java:332)
at com.jaspersoft.studio.server.publish.Publish.publishResources(Publish.java:189)
at com.jaspersoft.studio.server.publish.Publish.publish(Publish.java:65)
at com.jaspersoft.studio.server.publish.action.JrxmlPublishAction.publishReportUnit(JrxmlPublishAction.java:120)
at com.jaspersoft.studio.server.publish.action.JrxmlPublishAction$2.run(JrxmlPublishAction.java:94)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:236)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:146)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4975)
at com.jaspersoft.studio.server.publish.action.JrxmlPublishAction.doRun(JrxmlPublishAction.java:91)
at com.jaspersoft.studio.server.publish.action.JrxmlPublishAction.run(JrxmlPublishAction.java:63)
at com.jaspersoft.studio.server.editor.JRSEditorContributor.onSave(JRSEditorContributor.java:114)
at com.jaspersoft.studio.plugin.ExtensionManager.onSave(ExtensionManager.java:763)
at com.jaspersoft.studio.editor.AbstractJRXMLEditor.lambda$4(AbstractJRXMLEditor.java:681)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:236)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:146)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4975)
at com.jaspersoft.studio.editor.AbstractJRXMLEditor.doSave(AbstractJRXMLEditor.java:679)
at org.eclipse.ui.internal.SaveableHelper.lambda$0(SaveableHelper.java:156)
at org.eclipse.ui.internal.SaveableHelper.lambda$3(SaveableHelper.java:271)
at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:438)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:354)
at org.eclipse.ui.internal.WorkbenchWindow.lambda$5(WorkbenchWindow.java:2364)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:72)
at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:2362)
at org.eclipse.ui.internal.SaveableHelper.runProgressMonitorOperation(SaveableHelper.java:278)
at org.eclipse.ui.internal.SaveableHelper.runProgressMonitorOperation(SaveableHelper.java:260)
at org.eclipse.ui.internal.SaveableHelper.savePart(SaveableHelper.java:160)
at org.eclipse.ui.internal.WorkbenchPage.saveSaveable(WorkbenchPage.java:3838)
at org.eclipse.ui.internal.WorkbenchPage.saveEditor(WorkbenchPage.java:3851)
at org.eclipse.ui.internal.handlers.SaveHandler.execute(SaveHandler.java:57)
at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:283)
at org.eclipse.ui.internal.handlers.E4HandlerProxy.execute(E4HandlerProxy.java:95)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:58)
at org.eclipse.e4.core.internal.di.InjectorImpl.invokeUsingClass(InjectorImpl.java:320)
at org.eclipse.e4.core.internal.di.InjectorImpl.invoke(InjectorImpl.java:254)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.invoke(ContextInjectionFactory.java:173)
at org.eclipse.e4.core.commands.internal.HandlerServiceHandler.execute(HandlerServiceHandler.java:156)
at org.eclipse.core.commands.Command.executeWithChecks(Command.java:498)
at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:488)
at org.eclipse.e4.core.commands.internal.HandlerServiceImpl.executeHandler(HandlerServiceImpl.java:213)
at org.eclipse.ui.internal.handlers.LegacyHandlerService.executeCommand(LegacyHandlerService.java:392)
at org.eclipse.ui.internal.actions.CommandAction.runWithEvent(CommandAction.java:142)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:580)
at org.eclipse.jface.action.ActionContributionItem.lambda$5(ActionContributionItem.java:451)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4364)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1512)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1535)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1520)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1324)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4151)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3768)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1173)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1062)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:635)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:559)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at com.jaspersoft.studio.rcp.intro.Application.start(Application.java:91)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:660)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:597)
at org.eclipse.equinox.launcher.Main.run(Main.java:1468)

2. when I re-open the report on an older jaspersoft studio (6.10) I can't run the report in Studio. The error is:

net.sf.jasperreports.engine.JRException: org.xml.sax.SAXParseException; lineNumber: 235; columnNumber: 64; cvc-complex-type.3.2.2: Attribute 'textAdjust' is not allowed to appear in element 'textField'.
at net.sf.jasperreports.engine.xml.JRXmlLoader.loadXML(JRXmlLoader.java:302)
at com.jaspersoft.studio.editor.AbstractJRXMLEditor.doInitModel(AbstractJRXMLEditor.java:303)
at com.jaspersoft.studio.editor.AbstractJRXMLEditor.init(AbstractJRXMLEditor.java:246)
at org.eclipse.ui.internal.EditorReference.initialize(EditorReference.java:354)
at org.eclipse.ui.internal.e4.compatibility.CompatibilityPart.create(CompatibilityPart.java:340)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.e4.core.internal.di.MethodRequestor.execute(MethodRequestor.java:58)
at org.eclipse.e4.core.internal.di.InjectorImpl.processAnnotated(InjectorImpl.java:1001)
at org.eclipse.e4.core.internal.di.InjectorImpl.processAnnotated(InjectorImpl.java:966)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalInject(InjectorImpl.java:139)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:411)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:333)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:202)
at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.createFromBundle(ReflectionContributionFactory.java:91)
at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.doCreate(ReflectionContributionFactory.java:60)
at org.eclipse.e4.ui.internal.workbench.ReflectionContributionFactory.create(ReflectionContributionFactory.java:42)
at org.eclipse.e4.ui.workbench.renderers.swt.ContributedPartRenderer.createWidget(ContributedPartRenderer.java:132)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createWidget(PartRenderingEngine.java:1015)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:675)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.safeCreateGui(PartRenderingEngine.java:781)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.access$0(PartRenderingEngine.java:752)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$2.run(PartRenderingEngine.java:746)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:45)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.createGui(PartRenderingEngine.java:730)
at org.eclipse.e4.ui.workbench.renderers.swt.StackRenderer.showTab(StackRenderer.java:1294)
at org.eclipse.e4.ui.workbench.renderers.swt.LazyStackRenderer.lambda$0(LazyStackRenderer.java:75)
at org.eclipse.e4.ui.services.internal.events.UIEventHandler.lambda$0(UIEventHandler.java:38)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:236)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:146)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4975)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application$1.syncExec(E4Application.java:219)
at org.eclipse.e4.ui.services.internal.events.UIEventHandler.handleEvent(UIEventHandler.java:38)
at org.eclipse.equinox.internal.event.EventHandlerWrapper.handleEvent(EventHandlerWrapper.java:205)
at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:203)
at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:151)
at org.eclipse.equinox.internal.event.EventAdminImpl.dispatchEvent(EventAdminImpl.java:132)
at org.eclipse.equinox.internal.event.EventAdminImpl.sendEvent(EventAdminImpl.java:75)
at org.eclipse.equinox.internal.event.EventComponent.sendEvent(EventComponent.java:44)
at org.eclipse.e4.ui.services.internal.events.EventBroker.send(EventBroker.java:55)
at org.eclipse.e4.ui.internal.workbench.UIEventPublisher.notifyChanged(UIEventPublisher.java:63)
at org.eclipse.emf.common.notify.impl.BasicNotifierImpl.eNotify(BasicNotifierImpl.java:424)
at org.eclipse.e4.ui.model.application.ui.impl.ElementContainerImpl.setSelectedElementGen(ElementContainerImpl.java:170)
at org.eclipse.e4.ui.model.application.ui.impl.ElementContainerImpl.setSelectedElement(ElementContainerImpl.java:188)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.showElementInWindow(ModelServiceImpl.java:652)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.bringToTop(ModelServiceImpl.java:616)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.delegateBringToTop(PartServiceImpl.java:791)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.bringToTop(PartServiceImpl.java:404)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.showPart(PartServiceImpl.java:1240)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:3209)
at org.eclipse.ui.internal.WorkbenchPage.lambda$9(WorkbenchPage.java:3114)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:72)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:3112)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:3083)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:3066)
at org.eclipse.ui.ide.IDE.openEditor(IDE.java:637)
at com.jaspersoft.studio.utils.SelectionHelper.openEditorType(SelectionHelper.java:400)
at com.jaspersoft.studio.server.action.resource.OpenInEditorAction.lambda$0(OpenInEditorAction.java:215)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:40)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4103)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3770)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1173)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1062)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:635)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:559)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at com.jaspersoft.studio.rcp.intro.Application.start(Application.java:91)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:660)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:597)
at org.eclipse.equinox.launcher.Main.run(Main.java:1468)
Caused by: org.xml.sax.SAXParseException; lineNumber: 235; columnNumber: 64; cvc-complex-type.3.2.2: Attribute 'textAdjust' is not allowed to appear in element 'textField'.
at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(Unknown Source)
at org.apache.xerces.util.ErrorHandlerWrapper.error(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.xs.XMLSchemaValidator$XSIErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.xs.XMLSchemaValidator.reportSchemaError(Unknown Source)
at org.apache.xerces.impl.xs.XMLSchemaValidator.processAttributes(Unknown Source)
at org.apache.xerces.impl.xs.XMLSchemaValidator.handleStartElement(Unknown Source)
at org.apache.xerces.impl.xs.XMLSchemaValidator.startElement(Unknown Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
at org.apache.commons.digester.Digester.parse(Digester.java:1892)
at net.sf.jasperreports.engine.xml.JRXmlLoader.loadXML(JRXmlLoader.java:298)
... 86 more

#11
  • Resolution:Reopened» No Change Required
  • Status:Feedback Requested» Resolved
  • Assigned:nobody» teodord

Musa,

What is the version of JasperReports Server that you are trying to upload the JRXML onto. Are you sure is the latest 7.5, so that it is able to understand the latest version of JRXML?
In case we are indeed talking about an older JRS, then make sure you save your JRXML in that older version, as Jaspersoft Studio has an option to save JRXML in previous version formats.
It is an option in the Preferences and one also on the JRS connection properties.

I hope this helps.
Teodor

#12
  • Assigned:nobody»

Hi Teodor,

I am running JRS 7.1.1.

Just followed your advice and downgraded the JasperReports Library to version to 6.4.0 on the JRS connection configuration.

That seems to have fixed it. Able to publish now and view.

Thanks a lot.

Musa

#13

Hi,
I have upgraded the jasperreports to 6.11.0 from its previous 6.10.0 version.
We noticed an issue with the text wrapping turned into truncation. As suggested I tried replacing textField isStretchWithOverflow="true" to textField textAdjust="StretchHeight".
But I do not see any change in the behavior. The text continue to truncate instead of wrap (vertically)

Is there any other setting I am missing like updating to new DTD etc? I see the new DTD link is not working http://jasperreports.sourceforge.net/xsd/jasperreport.xsd

Please suggest.

Thanks

#14

I'm also facing the same problem, searched for many hours with no results.
this affects not only visualization of data but also the exported data. everything is truncated by default.
the server is using jasperreports 7.1 while the latest jasper studio is 6.12! I can't downgrade the server as well because the new features are a dependency for me. documentations don't say that I can't use "textAdjust" but the server rejects it.

@TIBCO Please do your job properly or fix this major issue ASAP. I see many people complaining about it for months. At least update the documentations to match the implementation.

#15
  • Assigned:nobody» teodord

Hi,

JasperReports Server does no longer have version numbers in sync with the library. If you take a look at your WEB-INF/lib in the server you probably see jasperreports-6.4.3x.jar.
For example, latest JRS 7.5.0 comes with JRL 6.11.0. So by using JRL 6.12.0 you would actually make an upgrade.

Having said that, it is normal that reports created with a newer JSS do not work on an older JRS. But in JSS you have a preference setting which allows you to save the JRXML in an older version and thus be able to deploy it on your older server.

Thank you,
Teodor

#16
  • Priority:High» Normal
  • Status:Resolved» Confirmed
  • Assigned:nobody»

Hi,

I have lost several hours to discover what means error 500 by publish my report to server on jasper reports, the problem is that option "Text Adjust".
Now i have to use option "CutText" to publish it, which cut the text on size of container and don't grow with text size.

Early versions were a good software to generate reports, but now it's like walking through hell...

B.Santos

Feedback
randomness