[#12286] - Band splitType="Stretch"

Category:
Bug report
Priority:
Normal
Status:
Resolved
Project: Severity:
Minor
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

Hi,

Trying Preventing band split. I need to use splitType="Stretch" atribute, but i'm not capable to make it work.
The page has only 50 px avaliable and the band height is 60 px, but band start rendering in this page instead of next.
Maybe something I miss?

v6.6.0
dgarciam's picture
Joined: Oct 29 2019 - 1:19am
Last seen: 7 months 2 weeks ago

10 Comments:

#1
  • Status:New» Feedback Requested
  • Assigned:nobody» teodord

Hi,

Can you post here the JRXML? The band is 60 px in height at design time or at runtime?

splitType="Prevent" would not be a better choice for you?

Thanks,
Teodor

#2

Hi,
Here is teh JRXML. The splitType="Prevent" doesen't work in my case.

AttachmentSize
Binary Data blank_a4.jrxml9.06 KB
#3

Hi,

I generated your report using JRL 6.6.0 and I see the second detail band going to the second page, as expected. Not sure what is not working in your case. Can you send a PDF with what you obtain?
Attached is the PDF I generated on my side. The white space left at the bottom of the first text field is there because you did not specify any font in your report and default fonts are different between Java AWT and PDF, so they fit differently. Nevertheless, you can see how the page break occurred in the right place.

Thanks,
Teodor

AttachmentSize
PDF icon fontsreport.pdf4 KB
#4

Hi,
This is the PDF.
Thx,

AttachmentSize
PDF icon report1565608284754070089.pdf11.37 KB
#5

Hi,

Indeed, I see now the problem and I agree it seems that the splitType=Stretch is ignored for the second band onward in a multi-band section.
The workaround for you is to simulate the detail band using the group header or group footer of a dummy group that breaks with every record.

Thanks,
Teodor

#6
  • Status:Feedback Requested» Acknowledged
#7
  • Resolution:Open» Fixed
  • Status:Acknowledged» Resolved

Hi,

This is fixed in the Git repo and will be part of the next release.

Thanks,
Teodor

#8

Thanks a lot,
Somewhere can I see it please?

#9
#10

Thanks

Feedback