[#12231] - Docx is being created with a grid layout in jasperreports

Category:
Bug report
Priority:
Urgent
Status:
Resolved
Project: Severity:
Block
Resolution:
Won't Fix
Component: Reproducibility:
Unable to Reproduce
Assigned to:
0

I need to create a docx with jasperreports that the user is able to edit it, but because the document has this grid layout when it's created, it's impossible to edit it, there's another question about this in the community, but jasper hasn't solved the problem.
What I found out worked for me was that when I create a pdf and converted it to docx with 'Ilovepdf' the document is perfect, but I can't find a cheat/free way to make my system convert it.

v6.7.0
JasperReports
davibogo's picture
Joined: Jul 3 2019 - 11:16am
Last seen: 1 month 3 weeks ago

4 Comments:

#1
#2
  • Assigned:nobody» teodord

Hi,

We are not going to change the grid nature of the DOCX exporter because there is no better alternative for absolute positioning content on the page. Using text boxes has other drawbacks such as text being cut and it would not solve your editable document problem anyway.

Please try set the following property in the JRXML report template:
http://jasperreports.sourceforge.net/config.reference.html#net.sf.jasper...

I hope this helps.
Teodor

#3

Hi,

Also, depending on what the actual report is made of, placing bigger pieces of content in frames and then using the following configuration property for DOCX export might give you the effect you need:
http://jasperreports.sourceforge.net/config.reference.html#net.sf.jasper...

I hope this helps.
Teodor

#4
  • Resolution:Reopened» Won't Fix
  • Status:Feedback Requested» Resolved
Feedback
randomness