[#11626] - The Map Element doesn't display in a subreport

Category:
Bug report
Priority:
Urgent
Status:
Resolved
Project: Severity:
Major
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
0

The element Map (in order to display a google map) doesn't work in a subreport.
If i test the subreport, the map displays with no problem. But if i test the main report, the map doesn't display (in the subreport).

v6.6.0
Google Map
poucepouces's picture
Joined: Jan 28 2016 - 8:06am
Last seen: 1 year 6 months ago

5 Comments:

#1
  • Severity:Minor» Major
#2
  • Assigned:nobody» shertage
#3

Hi,
we cannot reproduce the problem locally. Could you post the sample report and subreport, in order to help us figure out this issue?
Anyway, to get expected results when using Google maps, make sure you have a valid Google API key enabled for Maps JavaScript API, Maps Static API and Geocoding Service. This key can be set either in the report itself, or in a javascript.properties file in your classpath.
See more about Google Maps Platform and API keys here: https://developers.google.com/maps/gmp-get-started

#4
  • Resolution:Open» Unable to Reproduce
  • Status:New» Feedback Requested
#5
  • Status:Feedback Requested» Resolved

Hi,

Feel free to reopen this if you can provide more details about the problem.

Thank you,
Teodor

Feedback