[#10601] - Upgrade barcode bundle's ZXing Library from version 3.2.1 to the latest (3.3.2) for additional features

Category:
Enhancement request
Priority:
Normal
Status:
Acknowledged
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

The latest version of ZXing library supports additional QR code generation parameter: QR_VERSION. Additional encoding hints could be supported through visual component properties as well. We need this feature to generate valid QR codes for printing.

https://zxing.github.io/zxing/apidocs/com/google/zxing/EncodeHintType.ht...

Barcode4j
ztine77's picture
Joined: May 23 2011 - 11:00pm
Last seen: 9 months 6 days ago

2 Comments:

#1
  • Status:New» Acknowledged

Hi I will move the bug to the JR project.
They will take care of upgrading the dependency and modify related code in the component, if needed.
Once they have done we will give it a look on our side.

Regards,
Massimo.

#2

This sounds great!

Feedback