[#10516] - break element not working correctly

Category:
Bug report
Priority:
High
Status:
Feedback Requested
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

We conditionally needs page breaks that are put into group-headers.

Neither in 6.4.1 nor in 6.5.1 does this work 100% correctly with different symptoms.

With 6.5.1. there are empty pages between the page breaks. With 6.4.1 there are sometimes uncorrect renderered pages.

In our example there should by a page break before "Titel 1", "Titel 2" and "Klasse 3".

6.5.1. renders correct but insert empty pages, 6.4.1 did not produce the empty pages but renders "Klasse 3" incorrectly.

Thank you
Martin

AttachmentSize
PDF icon 6.5.1.pdf66.59 KB
mwrekers's picture
Joined: Jun 23 2011 - 1:00am
Last seen: 2 weeks 3 days ago

4 Comments:

#1
AttachmentSize
PDF icon 6.4.1.pdf64.98 KB
#2
AttachmentSize
Binary Data angebot.jrxml31.38 KB
#3
  • Status:New» Feedback Requested
  • Assigned:nobody» teodord

Hi,

I think that the extra blank pages in 6.5.1 are cause by some unfortunate combination of page break elements and the "keep together" flag of the groups.
I cannot run the report as I don't have the data, but it would be good if you could point to me which blank pages should not be there and I think I can explain why are there.

We might need to rethink this combination of page break elements and keep together in this report template to avoid double breaking like that.

Thanks,
Teodor

#4

In 6.5.1.pdf Page 3 & 5 should not be there.

Feedback
randomness