[#10291] - Update to Lucene 6.x.x

Category:
Enhancement request
Priority:
High
Status:
New
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

Both Lucene 4.x.x and 5.x.x depend on the project EOL jakarta-regexp:jakarta-regexp not touched since 2003. The Veritas security team are telling us we can't use JasperReports (and therefore DynamicJasper) as a result.
The Lucene 6.x.x branch does not seem to depend on jakarta-regexp:jakarta-regexp so requesting updating JasperReports to use Lucene 6.x.x

richard.jones's picture
Joined: Jan 12 2018 - 9:47am
Last seen: 4 months 2 weeks ago
Feedback
randomness