[#790] - Use different java compiler

Category:
Feature request
Priority:
Low
Status:
Assigned
Project: Severity:
Trivial
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

Issue moved from:
https://sourceforge.net/tracker/index.php?func=detail&aid=1490014&group_...

Consult the original issue for any attachments.

[ 1490014 ] Use different java compiler

Submitted By: Code_Slave - code_slaveAccepting Donations
Date Submitted: 2006-05-16 23:55
Last Updated By: gt78 - Comment added
Date Last Updated: 2006-06-01 09:34
Number of Comments: 1
Number of Attachments: 0

Assigned To: Nobody/Anonymous
Priority: 5

Summary:
Use different java compiler

Hi,

there is an issue related to java versions.

for example , the current jasperreport.jar is compiled with java 1.4.2 on the mac there is a transition from java 1.4.2 to 1.5

as I reports runs under both , on the mac , because 1.5 is the default the reports are being compiled for 1.5, so that when the .jasper file is transported to a platform ith 1.4 as the default , the reports are crashing jasperreport.

basically we need a way to cause a system running ireports under 1.5 to be able to use other java compiler versions.

in affect make the report compiling independent of the version used to run ireports

this may be needed in future as sun rolls out different versions of the jvm

Comments

Date: 2006-06-01 09:34
Sender: gt78SourceForge.net SubscriberProject Admin
Logged In: YES
user_id=616744

why do not try to use JDT compiler?

Anyway I'll move this request to the RFE tracker. It's not a bug.

Giulio

No Files Currently Attached

tcloonan's picture
712
Joined: Dec 22 2006 - 1:13am
Last seen: 12 years 7 months ago
Feedback
randomness