[#5621] - uploading a JasperReport with subreports results "Message: (NULL)"

Category:
Bug report
Priority:
Normal
Status:
Assigned
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:

I create the report, and the subreport correct: if I press preview in the iReport it works correctly.

But when I upload it to the server using the server repository it fails: I don't get the dialog "replace this by that " (${dir} +subreport.jasper" with "repo:subreport.jrxml" instead I get an exception displaying: "Message: (Null)"

maarten@stachanov.com's picture
Joined: Jan 24 2012 - 2:29am
Last seen: 7 years 8 months ago

4 Comments:

#1

I get "Error message:Null" when uploading a brand new report from iReport 4.5.0 to JasperServer 4.5.0 even without subreports. However, the report does get uploaded. The error is confusing.

#2

I am experiencing the same issue with any local resource including sub-reports or images. The report does upload, but without the object. A workaround, after the error, is to update the report on the server with the current jrxml. This will properly launch the dialog to convert local references to repository references (i.e. c:\\ to repo:)

#3

I am also facing same error. If I open ireport 3.0 version jasper file in ireport 4.5.0 and add some fields in the same report query and press read fields button. I have get same Error:null message.

Please give me the solution on the same.

-Anagha

#4

I hit this problem all the time. The work flow doesn't work very well.

* Using the wizard you get $P{SUBREPORT_DIR} + subreport.jasper
* Locally it can be $P{SUBREPORT_DIR} + subreport.jrxml or $P{SUBREPORT_DIR} + subreport.jasper
* JasperReports Server uses repo:subreport.jrxml
* To upload the subreports must be linked as JRXML, $P{SUBREPORT_DIR} + subreport.jrxml
* After upload it won't work locally, it will now be linked as repo:subreport.jrxml

I resort to checking in my files to my local source control. Uploading them to Jasperserver. Then rolling back from source control to maintain my $P{SUBREPORT_DIR} + subreport.jrxml references.

Feedback
randomness