[#5118] - Version 4.0.0 - Query Button - No Response- Hangs Machine

Bug report
Project: Severity:
Component: Reproducibility:
Not Attempted
Assigned to:

Version 3.7.6 Works fine. Upgraded to 4.0.0. - Create a report using any type of datasource and when the query button is clicked, the frame of the window changes color slightly and the application hangs. Nothing else happens from the user perspective. I have to go into task manager and delete the process. Upgraded to 4.0.1 and same problem exists. Went back to Version 3.7.6 and it continues to work.

lchalupa's picture
Joined: Dec 27 2010 - 9:20am
Last seen: 9 years 10 months ago



Same for me. When I go back to version 4.0.0. works fine but using 4.0.2. or latest 4.1.1. freezes the app.


4.0.2 worked for me for some time, tried to use 4.5 and had the hang problem. Now several months later, my 4.0.2 doesn't work anymore. I updated my video driver and bios, but would seem irrelevant.


More info, I went back to 3.7.6 that I had left installed on my machine, it now also hangs when I hit the query button.


I was able to get 4.5.0 to work by un-installing it, then installing it fresh and NOT importing parameters from early, older install. I had to re-enter all the configuration data which was a drag, but it is now working for me.


I have what I think is the same problem in 4.0.0 - I am suddenly no longer able to edit the queries for *any* reports. (I can go into the XML and edit them, but then have to also manually edit the field listing to match; this is a very laborious process, but seems to work.)

I am desperate for a work-around or re-install solution that doesn't involve manually deleting and recreating all configuration data and parameters! (We can't upgrade iReport, as we have the same stack on numerous offline computers.)


Very odd issue. Does it happen on all the computers you have?
I suspect it could be the JDBC driver, but the causes could be several.

Does happen even with the most simple query?

There is a log file in <user home>/.ireport/4.0.0/var/messages.log (or something like that)
can you check if you see any strange exception there?


Thanks for such a quick response. The following appears in the logs - I think it's probably just the third-last line that's relevant...

WARNING [org.openide.util.ImageUtilities]: Initial slashes in Utilities.loadImage deprecated (cf. #20072): /com/jaspersoft/ireport/jasperserver/res/folder.png
Charset used: UTF-8!!!!
WARNING [org.netbeans.core.multiview.MultiViewTopComponent]: The MultiviewDescription instance class com.jaspersoft.ireport.designer.JrxmlTextView is not serializable. Cannot persist TopComponent.
Charset used: UTF-8!!!!
Charset used: UTF-8!!!!
Charset used: UTF-8!!!!
Active top component: file_1335663599872.jrxml C:\Users\msiuser\AppData\Local\Temp\jstmp\file_1335663599872.jrxml
Query excuter found which is null!
Set Dataset: net.sf.jasperreports.engine.design.JRDesignDataset@1a8b29c
Setting divider at 519

Does this mean anything to you? I'm desperate to find a solution to this issue - even completely un-installing and re-installing Jasper Server hasn't resolved it!!!



After a very clever piece of detective work, a colleague of mine has solved this problem. By examining both the iReport source code and configuration files, he realised that the coordinates for the query window were actually outside of the active window - ie the query window *was* actually popping up when the button was clicked, but it was being painted off-screen, where it couldn't be seen or manipulated.

This was because I'd been using a dual-screen setup at home, then hibernated my laptop, then resumed it with just a single screen, and then opened the query window.

THIS IS A SERIOUS BUG IN iREPORTS! If the last location of the query window was off-screen, then iReports should ensure that those screen coordinates are still valid before opening the query window (and effectively freezing iReport).

Johnbergman, you didn't need to reinstall Jasper - you just needed to reset the screen coordinates in the configuration files...


Related to ticket: [#2984] - Designer showing UI window outside of a single screen boundaries

It would help to others if you indicated which config file stores coordinates and how to reset it.


It sounds like this bug is inherited from netbeans: https://netbeans.org/bugzilla/show_bug.cgi?id=164529
So not sure if JasperSoft can do anything about it.

  • Resolution:Open» Fixed

I realize that this is an old post, but I want to help others who may stumble across this thread. My query dialog box was also appearing off screen and the proper file to edit was the ireport.properties file. The line to edit was "ReportQueryDialog.position.x=". In my case, changing the X coordinate to 0 returned my dialog box to visible space on my screen. The post that resolved my issue was by dhoppmann posted here: http://community.jaspersoft.com/questions/803484/clicking-database-icon-....


Crashes after created report

Binary Data firstapplication.jrxml7.24 KB