[#4215] - iReport 3.5.3 compatibility save issue relating to components

Category:
Bug report
Priority:
Low
Status:
Assigned
Project: Severity:
Trivial
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

Saving a report using iReport compatibility does not remove components which are not supported by earlier versions of jasperreports

baggypants's picture
Joined: Apr 7 2009 - 12:43am
Last seen: 9 years 10 months ago

1 Comment:

#1

Me and Teodor talked a lot about this particular thing. We were aware about the problem, but the points are:
1. components are technically supported from JasperReports 3.1.0
2. some component don't work if not used with a particular version of JR, but this version is not marked anywhere
3. thirty party components can suffer of the same problem (unknow compatibility)

i.e. if you add the classes of JR 3.5.1 that implement the barcode component inside iReport (keeping the old JR core) your report will work, but this is not true for the List component introduced in 3.5.2.

So we can add a notice in the compatibility dialog about the fact that components are saved even if it is not sure which version of JR they are compatible with.

For now I think I'll leave this bug in stand by. We'll see if other people will vote for it.

Thanks a lot

Giulio

Feedback
randomness