[#4032] - not saving language attribute for jasperReport tag

Category:
Bug report
Priority:
Normal
Status:
Closed
Project: Severity:
Minor
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:
0

I'm editing my reports with iReport 3.5.2, and it does not save the attribute "language" for the root tag, jasperReport.

When I try to compile the report (with my own software), I get an exception:

net.sf.jasperreports.engine.JRException: No report compiler set for language : null
at net.sf.jasperreports.engine.JasperCompileManager.getCompiler(JasperCompileManager.java:508)
at net.sf.jasperreports.engine.JasperCompileManager.compileReport(JasperCompileManager.java:219)
at net.sf.jasperreports.engine.JasperCompileManager.compileReportToFile(JasperCompileManager.java:135)
at net.sf.jasperreports.engine.JasperCompileManager.compileReportToFile(JasperCompileManager.java:117)

If I set the language in the jrxml file, it works fine.

bzz's picture
bzz
1
Joined: Jun 11 2009 - 4:24am
Last seen: 9 years 11 months ago

2 Comments:

#1

Thanks for your submission. You are trying to use a new version of jrxml with an old version of the library. What you do chainging the header is modify the way the jrxml is validated. From 3.1.0 JasperReports uses an xsd based validation. Since the DTD is no longer specified in the header, old compilers not aware of the new xsd validation are not able to use the default values (which include the value Java for the attribute language).
Solution: upgrade to a new version of JasperReports, or use the new compatibility mode introduced in iReport 3.5.2 and fixed in 3.5.3.

#2
AttachmentSize
Binary Data web_service_test.jrxml6.48 KB
Feedback