[#3909] - Property values (selectable) dont show on Mac OS X

Category:
Bug report
Priority:
High
Status:
New
Project: Severity:
Minor
Resolution:
Reopened
Component: Reproducibility:
Always
Assigned to:
2

All selectable property values (via combo box) dont show up in property inspector, even they all have values. See screenshot attached. This makes iReport NB nearly unusable.

The only way to see what is currently selected is to click inside the property field. Then the value shows up. When leaving the field, it gets emtpy again.

AttachmentSize
Image icon propbug.png29.98 KB
loge's picture
52
Joined: Apr 23 2009 - 5:37am
Last seen: 4 years 1 month ago

10 Comments:

#1

any news on that? This is really annoying and seems to be a NB platform bug right? Never seen this issue at a colleague using Windows. Seems to be a Mac only issue.

#2

I know, I'm aware about this problem, I tried to investigate on it involving the NetBeans guys too without find a solution (they say the code should work properly, but it does not....).
I'll investigate more.

#3

tell me if i can help out testing things... assuming you dont have a mac at your hands. I am willing to help to solve this.

#4

Actually I have a Mac :-) NetBeans works properly, so it must be something on my side, but I'm not sure where...

#5

as a sidenote: even running iReport with Java6 on Mac makes no difference. Before i used Java5 together with iReport.

#6

Any news on that? Really annoying not to see the property values for selection lists. Really hard to work with the tool then....

#7

hard to believe that this is still open. Seems you completely ignore Mac OS X. I mean, this bug is a real BLOCKER in terms of UI issues.

#8

This used to be an issue with the Netbeans 6 IDE as well. I think it was patched in NB 6.1. I noticed the iReport.app bundle is distributed with nb6.0 and platform7 folders. I replaced platform7 with a platform9 folder from Netbeans 6.5 and the issue went away.

#9

FIXED!! I just moved iReport on Platform 6.5.1. This was the only way to fix this problem on Mac OS X, and my reticence on changing platform is the reason for which this bug remained open so long.

The fix will be present in iReport 3.6.1. Sorry for the delay guys.

Giulio

#10
  • Severity:Critical» Minor
  • Resolution:Fixed» Reopened
  • Status:Closed» New

This appears to be a problem again. Running Mac OS X (10.12 Sierra). Tried iReport 5.1.0, 5.5.0, 5.6.0. Tried java 6 and java 7. Both the standalone iReport version and the NB Plugin. Anyone experiencing the same problem?

Feedback
randomness