[#2656] - html component is not working

Category:
Bug report
Priority:
High
Status:
New
Project: Severity:
Critical
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:

Hi, I am trying to use the html component in iReport, version 5.0

The content of the html is not correctly rendered: so, the size of the field is correctly calculated, but all the content is tight in the small upper left corner (see figure errorHtmlComponent.png).

ALSO: whenever I try to modify the options Horizontal/Vertical Alignment or Scale type, iReport stops work: you can not save or preview anymore.

I observed this behavior also in previous versions.

Only version 4.5.1 showed the html correctly (see figure correcthtmlcomponentver4.5.1.png)

Thanks

COMMENT ON ATTACHED PICTURES:
- the jrxml template and the xml source are identical in both cases.

- Here is the xml source of the html component field:

<prjc_description>&lt;h3 style="color:blue;"&gt;
This project has rich text field&lt;/h3&gt;
&lt;p&gt;
&lt;strong&gt;Here is bold&lt;/strong&gt;&lt;/p&gt;
&lt;p&gt;
&lt;em&gt;Here is italics&lt;/em&gt;&lt;/p&gt;
</prjc_description>

v5.0
carlogenohm's picture
Joined: May 15 2012 - 5:18am
Last seen: 4 months 1 week ago

2 Comments:

#1
  • Priority:Normal» High
  • Severity:Minor» Trivial
  • Assigned:nobody»

HI I have the same problem when working with html component with in iReport 4.8 community edition ... server is 5.0
Plz fix the bug and let us know what's the mistake in using it.
It is showing some error like Abstract error.
What does it ??
Plz resolve.. it's urgent.
Thank you in Advance.

#2
  • Severity:Trivial» Critical
  • Reproducibility:N/A» Always
  • Assigned:» anonymous

Same here, version 5.0.1, please resolve

Thank you!!

Feedback
randomness