[#1003] - Scriptlet call does not change name when using "Save As..."

Category:
Bug report
Priority:
Low
Status:
Assigned
Project: Severity:
Trivial
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

Original issue: http://sourceforge.net/tracker/index.php?func=detail&aid=1242431&group_i...

[ 1242431 ] Scriptlet call does not change name when using "Save As..."

Submitted By: Nobody/Anonymous - nobody
Date Submitted: 2005-07-21 09:49
Last Updated By: netslayer - Comment added
Date Last Updated: 2005-08-30 11:07
Number of Comments: 2
Number of Attachments: 0

Assigned To: Nobody/Anonymous
Priority: 5

Summary:
Scriptlet call does not change name when using "Save As..."

Thank you for the great product... it helped me so much.

One problem I found was that when I tried to save my report under a different name (I had appended "_test" onto the end) the scriptlet call within the report did not change with the new filename, and so I would get ClassNotFound errors when filling the report. So I'm going to have to put a report into production with "_test" on the end of the filename... which is something I'd obviously rather not do. Hope this helps
as a suggestion.

-- Jake
"Narso"

Comments

Date: 2005-08-30 11:07
Sender: netslayer
Logged In: YES
user_id=762122

I guess I did report this (duplicate) 1260371

Date: 2005-08-30 11:05
Sender: netslayer
Logged In: YES
user_id=762122

I noticed this too.. I could swear I reported it, guess not. The Java scriptlet classnames are not getting updated according to the newly changed jasper report filename.

tcloonan's picture
643
Joined: Dec 22 2006 - 1:13am
Last seen: 12 years 5 months ago
Feedback
randomness