Jump to content
Changes to the Jaspersoft community edition download ×

Report not compiling - Sun Application Server


Recommended Posts

By: PJ Alarcon - pjalarcon

Report not compiling - Sun Application Server

2006-04-28 00:16

Hi,

 

I'm having trouble making JasperReports work on Sun Application Server 8 on a Solaris 10 machine.

 

Background info:

I loaded and compiled the jrxml file using the JasperCompileManager and filled the report using JasperFillManager:

JasperReport jasperReport = JasperCompileManager.compileReport("report.jrxml");

JasperPrint jasperPrint = JasperFillManager.fillReport(jasperReport, parameters, new JREmptyDataSource());

 

On Tomcat server on Windows XP and Ubuntu this works well. But when the webapp is moved to Sun application server on Solaris, it doesn't work. The application doesn't execute anything after the line: JasperReport jasperReport = JasperCompileManager.compileReport("report.jrxml");

But there is no error or stacktrace.

 

Do I have to set some other properties on the Sun app server? I have already added the following to my server.policy file:

 

grant {

permission java.lang.RuntimePermission "createClassLoader";

permission java.lang.RuntimePermission "getProtectionDomain";

permission java.lang.reflect.ReflectPermission "suppressAccessChecks";

};

 

Is there anything else that needs to be done for JasperReports to work on Sun app server? Any help would be appreciated.

 

Thank you,

PJ

 

 

 

 

 

 

By: jasperkan - jasperkannan

RE: Report not compiling - Sun Application Se

2006-05-03 07:05

i feel this could be because its not finding a java compiler . try adding jdt-compiler.jar to the classpath or make an entry to the javac compiler directory

 

 

 

 

By: N Olding - oldingn

RE: Report not compiling - Sun Application Se

2006-05-03 13:37

You will need to start your Java software on Unix using 'java -Djava.awt.headless=true' in order for the JasperReports engine to work without signalling an X11 error.

Your post, however, indicates that this is not the problem.

What happens after you execute the compileReport()? What is the next line, and what do you mean by 'The application doesn't execute anything after the line'?

Nigel

 

 

 

 

By: Kaskalee - kaskalee

RE: Report not compiling - Sun Application Server

2006-05-06 10:23

i have problem with jasperCompileManager.compileReport() loading, i passed .jrxml file to it as inputstream and even tried to pass its url to it but all i got is error loading object. I'm using Sun Creator2 and Oracle database with Tomcat or sun App Server on windows Xp. Pls i need a solution to this problem.

You talked about server.policy how did you set your tomcat that worked for you.

I'll appreciate if you can help me out of this.

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...