Jump to content
Changes to the Jaspersoft community edition download ×

Problem setting up DB with sample data


mglubb

Recommended Posts

Hello,

 

I am trying to evaluate JasperIntelligence. I have checked and have the necessary system requirements.

 

When I attempt to execute:

 

./ji-import.sh --import-path=ji-catalog --import-file=ji-catalog.xml

 

from the scripts directory to import the sample Foodmart and Sugarcrm databases, I get the following error:

 

java.io.FileNotFoundException: class path resource [applicationContext-for-export.xml] cannot be opened because it does not exist

 

I have checked for the file and it exists in ./ji-export-util.

 

I have tried moving the file around into other directories but this does not seem to help.

 

I'd be grateful if someone could point me in the right direction to solving this. My environment is as follows:

 

java version "1.5.0_06" standard edition

OS X 10.4.7

apache-tomcat-5.5.17

mysql Ver 14.12 Distrib 5.0.24

 

Apologies in advance for my lack of java knowledge!

 

Regards,

 

Matt

Link to comment
Share on other sites

  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Hi Matt,

 

There is a shell script related bug under non-windows platforms. This may be what you are hitting. It has to do with how the command line gets parsed and handed off to the java code. Anyway, try this and see how it goes:

 

./ji-import.sh --foo --import-path=ji-catalog --import-file=ji-catalog.xml

 

Note the "--foo"

 

Also, check that the path and file names actually exist in the locations specified.

 

Let me know if this doesn't fix it.

 

Thanks,

 

-Tony

Link to comment
Share on other sites

Hi Tony,

 

Thanks for your reply. I tried what you suggested but I get the same error :(

 

Let me stress that I have not moved any files and I am executing that command from the scripts directory after following the steps in the Installation docs up to that point. It just can't seem to find applicationContext-for-export.xml. If I knew what the working directory of the import app was or knew where I could specify an absolute path for this file, maybe that would fix it.

 

Regards,

 

Matt

Link to comment
Share on other sites

Oops, I missed that it was the applicationContext-for-export.xml that was missing.

 

Can you tell me which package you used to get the application. Was it "JasperIntelligence-1.0.1-bin.zip" (ie. the stand-alone war files)?

 

You are using OS X 10, so I assume you didn't use the linux installer.

Link to comment
Share on other sites

  • 4 weeks later...

hi!

 

It seems like the path where applicationContext-for-export.xml is located (ji-export-util) is missing from the classpath.

 

Changing the last line in ji-import-export.sh from

java -cp "$EI_CLASSPATH" com.jaspersoft.jasperserver.util.ExportImportCommand $CMD $CMD_LINE_ARGS

to

java -cp "$EI_CLASSPATH:$JI_EXPORT_UTIL" com.jaspersoft.jasperserver.util.ExportImportCommand $CMD $CMD_LINE_ARGS

did the job for me.

 

Regards

Christian

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...